503 whmcs

503 service unavailabel hi after i swithch php v 7.0 to 7.3 it show error 503 services unavailable why whats wrong

CentOS or Ubuntu? I believe PHP 7.3 is not installed on your system.

Ubuntu with aws server i test in all 7.1 to 7.3 but its show 503

reboot server reinstall whmcs installl all of 7.3 Extension but not work

Use this guide and install on minimal Centos 7 fresh image.


thanks problem solved i take my all website back up and make a new machine aws with centos and restore my data witout losing any thing really thanks for help but i use previously AWS Marketplace: CyberPanel
i suggest try to update them

this issue is due to the ioncube loader with cyberpanel 7.2 7.3 etc all being outdated
You should still install it for the PHP version in use and then use that as a template to enable it.

How i fixed it.

  1. Put an phpinfo.php page in the directory of the site. go to the link

  2. ctrl+f look for “extension_dir”

  3. In my case it was
    For PHp 7.2
    for PHP 7.3

  4. Rename the original ioncube.so
    cd /usr/local/lsws/lsphp72/lib/php/20170718/
    mv ioncube.so ioncube.so.bak

cd /usr/local/lsws/lsphp73/lib/php/20180731/
mv ioncube.so ioncube.so.bak

  1. then upload the new copy of these loaders for those versions from Loader Download - PHP Encoder, protection, installer and performance tools from ionCube

cp /home/username/ioncube_loader_lin_7.2.so /usr/local/lsws/lsphp72/lib/php/20170718/ioncube.so

If your system default is php 7.2 there will be a cli for this version that needs the ioncube enabled as well so cronjobs will work.

use nano/vi etc to edit and append this to the end.
nano /etc/php/7.2/cli/php.ini
zend_extension = /usr/local/lsws/lsphp72/lib/php/20170718/ioncube.s
restart litespeed/openlitespeed

Should work for both CLI and website PHP