503 service unavailable in admin console :8090

Hello there, I’m having a problem with my CP after an update from ubuntu 18.04 to 20.04
All the pages are working good but the admin console, phpadmin and rainloop return 503 error.

systemctl status lscpd
is running but cant find python
/usr/local/CyberCP/bin/lswsgi: error while loading shared libraries: libpython3.6m.so.1.0>

systemctl start gunicorn
Failed to start gunicorn.service: Unit gunicorn.service not found.

I follow the step Manually set up virtualevn, restarted the services and server multiple times but the problem persisted.

Also tried apt-get udpate and upgrade.

Server is a little over 2 years old running CP.
Digital Ocean droplet - 2 GB Memory / 2 Intel vCPUs / 60 GB Disk.
Thinking to migrate to a fresh install but without the admin panel every task gets more complicated.

Thanks for the help

you can access the ssh ? install the missing or simply do and upgrade from the CP and it will work

1 Like

Tried upgrading twice this days, didn’t worked, tried again after your comment, now everything running good. Thanks!

I always recommend not to do a distro upgrade. It should be better that you set up a new server with CyberPanel and then transfer the sites over.

Now you may need to hire someone to fix the mess.

1 Like

I ran into the same issue and this solved the problem for me

source /usr/local/CyberCP/bin/activate
pip install --ignore-installed -r /usr/local/CyberCP/requirments.txt

virtualenv --system-site-packages /usr/local/CyberCP
systemctl restart gunicorn.socket

1 Like