443 not listening on the server and sites not working

Hi,

For me all sites are working only in http, not in https. I thogut it ws related to firewall that refuses to connect to the port 443 but not while checking open port in netstat the port 443 is not listening why is that?

[root@justtest public_html]# netstat -ntlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 127.0.0.1:8891 0.0.0.0:* LISTEN 2643/opendkim
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 450/dovecot
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 450/dovecot
tcp 0 0 0.0.0.0:7080 0.0.0.0:* LISTEN 7424/openlitespeed
tcp 0 0 0.0.0.0:587 0.0.0.0:* LISTEN 2729/master
tcp 0 0 127.0.0.1:5003 0.0.0.0:* LISTEN 1/init
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 450/dovecot
tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 621/spamd.pid -d -c
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 450/dovecot
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 7424/openlitespeed
tcp 0 0 0.0.0.0:465 0.0.0.0:* LISTEN 2729/master
tcp 0 0 0.0.0.0:53 0.0.0.0:* LISTEN 797/pdns_server
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 436/pure-ftpd (SERV
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 409/sshd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2729/master
tcp 0 0 0.0.0.0:8090 0.0.0.0:* LISTEN 152/lscpd (lscpd -
tcp6 0 0 :::993 :::* LISTEN 450/dovecot
tcp6 0 0 :::995 :::* LISTEN 450/dovecot
tcp6 0 0 :::3306 :::* LISTEN 5511/mysqld
tcp6 0 0 :::587 :::* LISTEN 2729/master
tcp6 0 0 :::3307 :::* LISTEN 618/mysqld
tcp6 0 0 :::110 :::* LISTEN 450/dovecot
tcp6 0 0 :::143 :::* LISTEN 450/dovecot
tcp6 0 0 :::465 :::* LISTEN 2729/master
tcp6 0 0 :::53 :::* LISTEN 797/pdns_server
tcp6 0 0 :::21 :::* LISTEN 436/pure-ftpd (SERV
tcp6 0 0 :::22 :::* LISTEN 409/sshd
tcp6 0 0 :::25 :::* LISTEN 2729/master
[root@justtest public_html]#

SSL listener is not there by default, you need to issue SSL for at least one site for it to be there. https://docs.cyberpanel.net/doku.php?id=issue_ssl_for_website

HI,
I have tried that multiple times.
I already created the site will ssl checked but not worked so that I issued the SSL multiple times but not even worked.

after issuing I got message as 'SSL Issued for ’ but not working.

note:
the site not actual one, just a dummy name like maxin.com is that the reason ?

cat /usr/local/lsws/conf/httpd_config.conf | grep  'listener SSL'

What is the output of this command?

Now I have added a valid working website to to the server called maxin.techamigo.in and it is correctly pointed to the server. Also I have issued SSL for it but still https is not working for it ?

output is
cat /usr/local/lsws/conf/httpd_config.conf | grep ‘listener SSL’
listener SSL {

that will display only one line, so I’m pasting whole 80 and 433 section

listener Default {
map maxin.techamigo.in maxin.techamigo.in
address *:80
secure 0
}

listener SSL {
map maxin.techamigo.in maxin.techamigo.in
address *:443
binding 3
secure 1
}

Looks like OpenLiteSpeed hit a bug, try

yum remove openlitespeed
yum install openlitespeed-1.4.36
mv /usr/local/lsws/conf/httpd_config.conf.rpmsave /usr/local/lsws/conf/httpd_config.conf
systemctl restart lsws

I have to say that it didn’t fixed the issue. I have removed the openlitespeed and installed that version openlitespeed-1.4.36 still faced the same issue.
so I have have reloaded my server and installed the panel again which is now working fine. https is working fine now

Need to remove this type of characters at " /usr/local/lsws/conf/httpd_config.conf"

“^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^”

Its finally fixed after removing these; and a reboot

1 Like

this is the solution, thank you very much,
This error occurred when I deleted websites, all websites were disabled, specifically the listeners were not working

If you followed the process you can write a complete guide for that and publish here that may be help full for the searchers