404 Not Found The resource requested could not be found on this server!

Hi Community,

I have recently created a new website on my cyberpanel which I am using for well over a year but I’m getting the attached error.

What steps I took:
Created new website
Installed Wordpress

Trying to access the website now but the issue is same.

Pls suggest what should I do to resolve this.

Delete htacces content and copy paste below there

BEGIN WordPress

RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

END WordPress

Sometimes even just going htacces section on site settings and press save will work too.

Hey Dreamer,

Appreciate your prompt response.but unfortunately this didn’t work.

Still nothing works…

Pls suggest a solution…

Did you check installer did install all wp files and database?
Can you go wp-admin?
Try also on file manager press fix permissions.

Oh yes… double checked everything… and deleted the website and reinstalled too… cleared memory and cache…

like what I could be missing???

RAM good, Space Good, Things are clear… using cloudflare and infact removed cloudflare to check if that is giving the trouble…

Still unable to figure it out…

Maybe try disable modsecurity and firewall.
Anything on logs?

modsecurity off and switched firewall now… just recreating the website now… but it is taking a hell lot of time to create a new website… .

I am checking my cloudflare settings as well if anything got tunedup there …

nothing in error logs… 2 unusual things…

  1. Takes ages to open Version Management link
  2. Takes ages to open Create Website link

what am I missing here I am still not able to figure it out…

Have you try install manually wordpress?

Still not resolved. Checked on tor.

OH man I guess I will have to wait and check again

Okay so the issue is now resolved…

And updating cyberpanel solved it and it’s components were giving the problem. But I had to wait for some 24 hours to see it working…

Since I’m using cloudflare for security, I was confused that the problem could be from CF but it wasn’t …

I still have my firewall ON | Modsecurity ON | no editing of .htaccess file

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.