404 Error using Deploy Wordpress / PHP: Not Found [Update 2]


I have installed CyberPanel with LiteSpeed Enterprise on a fresh installation of Ubuntu 22.04 LTS, fully patched and upgraded. During installation of CyberPanel, I followed all the default options.

I have tried to install my wordpress website using the Deploy Wordpress tool but get the following error:

Error message: [“Failed to install WordPress: error: sh: 1: /usr/local/lsws/lsphp74/bin/php: not found”," [404][404]"]

When I “Scan Wordpress” using the List Wordpress tool the website shows up and when I visit my domain it displays “CyberPanel Installed” but when I try to login using the wordpress login button, it takes me to a “404 Not Found” page. When I delete the website and rescan, it reappears.

Update 1
I have installed the php extension “lsphp74” as it wasn’t previously. Here are all the extensions installed for PHP 7.4:

lsphp74-apcu/jammy 5.1.21-1+jammy amd64
lsphp74-common/jammy,now 7.4.30-1+jammy all [installed,automatic]
lsphp74-curl/jammy 7.4.30-1+jammy amd64
lsphp74-dbg/jammy 7.4.30-1+jammy amd64
lsphp74-dev/jammy,now 7.4.30-1+jammy amd64 [installed]
lsphp74-igbinary/jammy,now 3.2.7-1+jammy amd64 [installed,automatic]
lsphp74-imagick/jammy 3.7.0-1+jammy amd64
lsphp74-imap/jammy 7.4.30-1+jammy amd64
lsphp74-intl/jammy 7.4.30-1+jammy amd64
lsphp74-ioncube/jammy 12.0.5-1+jammy amd64
lsphp74-json/jammy,now 7.4.30-1+jammy amd64 [installed,automatic]
lsphp74-ldap/jammy 7.4.30-1+jammy amd64
lsphp74-memcached/jammy,now 3.2.0-1+jammy amd64 [installed]
lsphp74-modules-source/jammy 7.4.30-1+jammy all
lsphp74-msgpack/jammy,now 2.1.2-1+jammy amd64 [installed,automatic]
lsphp74-mysql/jammy 7.4.30-1+jammy amd64
lsphp74-opcache/jammy,now 7.4.30-1+jammy amd64 [installed,automatic]
lsphp74-pear/jammy 1.10.13-1+jammy all
lsphp74-pgsql/jammy 7.4.30-1+jammy amd64
lsphp74-pspell/jammy 7.4.30-1+jammy amd64
lsphp74-redis/jammy,now 5.3.7-1+jammy amd64 [installed]
lsphp74-snmp/jammy 7.4.30-1+jammy amd64
lsphp74-sqlite3/jammy 7.4.30-1+jammy amd64
lsphp74-sybase/jammy 7.4.30-1+jammy amd64
lsphp74-tidy/jammy 7.4.30-1+jammy amd64
lsphp74/jammy,now 7.4.30-1+jammy amd64 [installed]

Problem is, using the same information I would like to create a new wordpress site, but it is stuck on “Starting creation…” and the website details is continuously loading. I’m thinking this is either because the previously failed wordpress site has not deleted properly (as mentioned above) or there is another issue.

Update 2
I installed the following extension:

lsphp74-mysql/jammy 7.4.30-1+jammy amd64

and also deleted the wordpress website using the “Delete Website” tool under the Websites tab and it was gone from the list of wordpress websites. Tried again and it worked.

This is now resolved but I’ll leave this up for anyone that also encounters this issue.

As mentioned in the post above, I have resolved this issue.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.