404 error on new default website. The preview works


I have installed latest version of cyberpanel Latest Version: 2.3 build :4 on a Centos 7.9 OS. I have created a fresh website and have not uploaded any files to the website, so the default index.html is the only file in the public_html folder. I have also not created a .htaccess file so no rewrite rules. I get a 404 error when I access the website by host name or ip address.

However with preview using ubuntubotholife.dedicated.co.za:8090/preview/ubuntubotholife.online/ the page renders correctly.

I have restarted lsws.

The only log entry related to this is in the access log:
[18/Aug/2023:18:20:11 +0200] “GET / HTTP/2” 404 705 “-” “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/115.0.1901.203”

I get same error in different browsers. I have also tried recreating the website. Also did suspend/unsuspend.

I have seen many posts related to the 404 issues but none of them are able to help me resolve my issue.

Please help