02 - Upgrading CyberPanel

Hi all! lurking for ages, posting first time :slight_smile:

I’m stuck on this message after an upgrade of CyberPanel from 2.3.1 to 2.3.2 on Ubuntu 20.04 (on GCP).

/usr/local/cyberpanel_upgrade.sh: line 604: /usr/local/CyberCP/bin/activate: No such file or directory

…and in effect, in that folder i’ve found only one folder named “pycache” and nothing else.

Any ideas?
Thanks for any advice!

I am using VPS cyber panel, and for the last few days I am facing an HTTPS error “Your connection is not private” I installed really SSL plugging and also issue SSL from the VPS panel, but the problem still exists, then I contact hostinger the says “self-signed SSL” but I don’t know how to self-signed SSL certificate please advice

Are these necessary updates? If I don’t update CyberPanel, what will happen?

not necessary, but sometimes needed for security updates or just using new feature

Hi I have try this command

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

via SSH to my VPS

It says “CyberPanel Upgraded” on Terminal, but not on the Dashboard on CyberPanel

Not sure what the issue is?

1 Like

it should be v2.3.2 right?

Same error on Centos 7


fine here . current commit match with latest , means that you have latest version.

I’m trying to update CyberPanel and the command is the same as given here:
See the errors that occur at the end of the print!!

It ends up giving an error at the end!

After giving this error mentioned above, not even a simple update command works anymore… I don’t understand that…

I can’t update and in the end it gives me other problems…

Anyone can help ?


What kind of downtime can we expect when upgraden/updating? Is there any downtime at all for the client websites?

@xmedia No downtime. An upgrade should not put your websites down

The upgrade can break all my site if it fail ?

@usmannasir Is it safe to upgrade from 2.3 to version 3?

I’ve tried upgrading to stable, v2.3.2 and v2.3.4-beta, but I keep getting the error below. Our CyberPanel is all the way back on v1.8.3 (not sure if that is a problem jumping forward so many versions).

Traceback (most recent call last):
  File "upgrade.py", line 2924, in <module>
  File "upgrade.py", line 2920, in main
  File "upgrade.py", line 2828, in upgrade
  File "upgrade.py", line 2726, in UpdateConfigOfCustomACL
  File "/usr/local/CyberPanel/lib/python3.6/site-packages/django/__init__.py", line 24, in setup
  File "/usr/local/CyberPanel/lib/python3.6/site-packages/django/apps/registry.py", line 114, in populate
  File "/usr/local/CyberPanel/lib/python3.6/site-packages/django/apps/config.py", line 211, in import_models
    self.models_module = import_module(models_module_name)
  File "/usr/local/CyberPanel/lib/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 994, in _gcd_import
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 665, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 678, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/usr/local/CyberCP/loginSystem/models.py", line 75, in <module>
    class Administrator(models.Model):
  File "/usr/local/CyberCP/loginSystem/models.py", line 87, in Administrator
    acl = models.ForeignKey(ACL, default=1)
TypeError: __init__() missing 1 required positional argument: 'on_delete'
above command failed...

Hi Usmannasir.
I currently have cyberpanel 2.3 (stable) installed.
I would like to upgrade to v2.3.4-dev due to the problems highlighted with regard to certificates.
Are there any contraindications to this?
If there are no problems, what should be the commands to upgrade?
Thanks for your help

hi, I tried to upgrade to the latest but I am getting this error !!!: “Please input a valid format version number.”


sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 396 100 396 0 0 2506 0 --:–:-- --:–:-- --:–:-- 2506

Fetching latest data from CyberPanel server…

This may take few seconds…

Checking root privileges…

You are running as root…

Checking server location…

System: AlmaLinux 8 detected…

Press the Enter key to continue with latest version, or enter specific version such as: 1.9.4 , 1.9.5 …etc

If nothing is input in 10 seconds, script will proceed with the latest stable version.

Please press the Enter key or specify a version number, or wait for 10 seconds:

Please input a valid format version number.

i am getting the same eror, what steps did you take to resolve the issue?

My cyberpanel Current Version 2.0 Build 3

Hosted in Centos 7, I wish to upgrade to latest version.

When I follow the instruction to upgrade:

sh <(curl https://raw.githubusercontent.com/.../stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/.../stable/preUpgrade.sh)

it stop halfway and I see this error:

WARNING: Running pip install with root privileges is generally not a good idea. Try pip3.6 install --user instead.

after that I follow again the instruction:

#pip3.6 install --user

it shows:

WARNING: Running pip install with root privileges is generally not a good idea. Try pip3.6 install --user instead.

You must give at least one requirement to install (see “pip help install”)

anyone experience this and able to share me some direction?
I see some say disable IPv6, I disable it via my VPS control panel, but still the same.

If I ignore the msg, the process just stop at this stage:

Collecting botocore==1.21.26
Downloading botocore-1.21.26-py3-none-any.whl (7.8 MB)
|██████▋ | 1.6 MB 22.5 MB/s eta 0:00Connection closed

Any suggestion what my next step?