Webistes Not Working - TimeOut (SSL Permission Denied)

Hi guys,

I am new to CyberPanel. I recently installed it on an Amazon Instance and managed to create some websites inside of the server. I have also updated my domains with the server IP address as an A record.

However, when I try to access my domain address via the browser. It loads until time out error.

"The connection has timed out
An error occurred during a connection to www.mydomain.com. "

As a result I cannot get to install SSL Certificates via let’s encrypt. It installs rather the self-signed one which is basically useless.

This is what I have done so far

  1. Cyber Pannel is Updated to latest Version
  2. Acme is also updated to the lastest version
  3. Disabled Mod Security and firewall
  4. I ran this command: /root/.acme.sh/acme.sh --issue -d mydomain.xyz -d w ww.mydomain.xyz --cert-file
    Resoponse: -bash: /root/.acme.sh/acme.sh: Permission denied
  5. Tried going into file managers of these domains and Click Fix Permissions
  6. Rebooted the server
  7. Try add the certificate to the host domain

with no luck. I am basically stuck.

Domains are properly configured and are pointed to the server but just wont resolve. I believe this is why SSL cannot install successfully.

As this is a public forum I would advise you to remove any details of your domain and server ip.

As you said you are new to cyberpanel, does that also mean are your new to Amazon aws too? If so, amazon has its own firewall security group where we need to open certain port numbers to make things work. Let me know if you are aware of this or not.

1 Like

Thanks for your reply. Yes, I am also new to Amazon. Any help in that regard will be appreciated.

You will need to allow these ports in the security group when creating new EC2 instance in aws like the screenshot below.


Thanks man. This really helped. Added the security rules and domain were resolving. Tried reissuing SSLs and it was still installing the self-signed one. I deleted all websites and receated them and the SSL is installing correctly!

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.