[Tutorial] How to setup and login to OpenLiteSpeed webadmin console

https://support.cloudflare.com/hc/en-us/articles/200169156-Identifying-network-ports-compatible-with-Cloudflare-s-proxy

CF only allows certain ports to be reverse-proxyed

I read about ports what you provided in the links.
And I don’t know why port 8090 causes conflict and error 522.
That’s why I wrote this topic. I have default ports in the firewall after a new installation + 7080.
I did the installation twice and the problem repeated.
For some reason, a new CyberPanel installation causes such a conflict.

I read about ports what you provided in the links. And I don't know why port 8090 causes conflict and error 522. That's why I wrote this topic. I have default ports in the firewall after a new installation + 7080. I did the installation twice and the problem repeated. For some reason, a new CyberPanel installation causes such a conflict.

may I know how did you set it up ?

you mean like you were accessing something like https://panel.domain.com:8090 and you got 522 ?

what if you access it directly https://YOUR_SERVER_IP:8090 ?

I use login via ip:
https://YOUR_SERVER_IP:8090
I also checked through the domain:
https://panel.domain.com:8090
In both cases, when domains are supported by cloudflare and port 8090 is unblocked, there is error 522.
Domains that have their own dns work OK.

I don’t think you can possibly unblock 8090 through Cloudflare ?

I don't think you can possibly unblock 8090 through Cloudflare ?

For domains to work via cloudflare, port 8090 must be blocked.
If the port is unblocked then domains served by cloudflare do not work because I have a 522 error.

I don't think you can possibly unblock 8090 through Cloudflare ?

For domains to work via cloudflare, port 8090 must be blocked.
If the port is unblocked then domains served by cloudflare do not work because I have a 522 error.

I’m sorry I’m bit of confused here, May I know what exactly is your issue here with CF?

I'm sorry I'm bit of confused here, May I know what exactly is your issue here with CF?

Unlocked port 8090 on which you login in to CyberPanel causes error 522 on all domains that I have supported via cloudflare. These domains do not work.

when you mean unlocked port 8090 , what exactly does that mean ? and what was your URL to access it ? https://domain.com , or https://domain.com:8090?

when you mean unlocked port 8090 , what exactly does that mean ? and what was your URL to access it ? https://domain.com , or https://domain.com:8090?

If port 8090 is unlocked for logging into CyberPanel:
https://IP:8090
Domains that are supported by cloudflare do not work. They show error 522.

What was the link you were using to access it ? With domain

What was the link you were using to access it ? With domain

If CyberPanel is on port 8090 and it’s open, nothing on cloudflare dns is working and showing error 522.
If I block port 8090 with a firewall, everything starts working OK. All domains are starting to work.
I write the same yuk several times in this topic.
An open port 8090 prevents you from using cloudflare services.
There is a bug in the cyberpanel.

actually I am still not getting what is your issue here.

please join the discord and contact me @qtwrk there , I will ask for some details.

Best regards,

If I have access to CyberPanel
https://ip:8090


I have this error on all domains that are cloudflare:

If I block login to the cyberpanel and I don’t have access, the domains work Ok.
If I want domains to work, I can’t use the CyberPanel admin panel because port 8090 is blocked.

ok , so if you access https://ip:8090 , it works , right ?

and in this image https://i.imgur.com/lBLYUOS.png

what was your access ? https://domain.com , or https://domain.com:8090 ?

Whether through https:// ip:8090 or https://domain.com:8090 is:
https://i.imgur.com/lBLYUOS.png
This guide is out of date and does not work on the current version 1.9.1:
How to remove port 8090 from CyberPanel - CyberPanel

@Nencio said:
Whether through https:// ip:8090 or https://domain.com:8090 is:
https://i.imgur.com/lBLYUOS.png
This guide is out of date and does not work on the current version 1.9.1:
How to remove port 8090 from CyberPanel - CyberPanel

And if you use domain without CF, it works?

Yes. Without CF, domains work OK.

Yes. Without CF, domains work OK.

when you say domains work , as https://domain.com it leads you to cyberpanel page, right ?

and actually I just did that tutorial on my test server and it works with CF enabled.

[root@cpanel ~]# curl -I -XGET https://xxxx.me
HTTP/1.1 200 OK
Date: Tue, 05 Nov 2019 22:29:06 GMT
Content-Type: text/html; charset=utf-8
Transfer-Encoding: chunked
Connection: keep-alive
Set-Cookie: __cfduid=d53b0fec021f1df12090596c39417413c1572992946; expires=Wed, 04-Nov-20 22:29:06 GMT; path=/; domain=.xxxx.me; HttpOnly; Secure
Cf-Railgun: direct (starting new WAN connection)
Content-Language: en
Set-Cookie: csrftoken=qDspwoxOsGBdGqW9aHOZxobghbmQKXciOHK4PadqwgTDH1Mr6B6Xx01RvhXCBtZp; expires=Tue, 03-Nov-2020 22:29:06 GMT; Max-Age=31449600; Path=/; secure
Vary: Cookie, Accept-Language,Accept-Encoding
X-Frame-Options: DENY
X-Turbo-Charged-By: LiteSpeed
X-Xss-Protection: 1; mode=block
CF-Cache-Status: DYNAMIC
Strict-Transport-Security: max-age=15552000
X-Content-Type-Options: nosniff
Expect-CT: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
Server: cloudflare
CF-RAY: 531243b99a6c97c0-FRA

as you can see , status 200 OK , and server: cloudflare

please check the screenshot , reverse proxy to panel with CF enabled , works.

you can see, CF extension indicates my connection is via their Amsterdam node with IP 104.27.149.241

so in your case, I think you may have some misconfiguration , in particular , I suspect something to do with options inside “SSL/TLS” tab

It does not lead to the cyberpanel page.
Leads to domain index.html.
This guide does not work on a new 1.9.1 installation:

Port 8090 conflicts with CF. Either you use CF with domains or CyberPanel admin login panel. At the same time, you can not use. CF has set up new hubs in Europe and may now be using CF 8090 proxy port for CF.
I have installed CyberPanel 2 times and each installation has the same error.

Guide:

Need to update.
How do I change the default CyberPanel login port from 8090 to another?
For me, the IP CF is different 104.27.174.39.

With the port 8090 operational:
curl -I -XGET https://xxxx.me
HTTP/2 522
date: Wed, 06 Nov 2019 02:40:21 GMT
content-type: text/html; charset=UTF-8
set-cookie: __cfduid=d279c7619aa7699fd58bb1ff1c256d2ef1573008015; expires=Thu, 05-Nov-20 02:40:15 GMT; path=/; domain=.xxxx.me; HttpOnly
cache-control: no-store, no-cache
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
set-cookie: cf_ob_info=522:5313b3a19a96d45b:HAM; path=/; expires=Wed, 06-Nov-19 02:40:51 GMT
set-cookie: cf_use_ob=443; path=/; expires=Wed, 06-Nov-19 02:40:51 GMT
expires: Thu, 01 Jan 1970 00:00:01 GMT
cache-control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
pragma: no-cache
server: cloudflare
cf-ray: 5313b3a19a96d45b-HAM

With port 8090 blocked:
curl -I -XGET https://xxxx.me
HTTP/2 200
date: Wed, 06 Nov 2019 02:41:36 GMT
content-type: text/html
set-cookie: __cfduid=d047202eea0c9cd626ffe177fca90b27c1573008096; expires=Thu, 05-Nov-20 02:41:36 GMT; path=/; domain=.xxxx.me; HttpOnly
last-modified: Sat, 19 Oct 2019 06:18:22 GMT
vary: Accept-Encoding
x-turbo-charged-by: LiteSpeed
cf-cache-status: DYNAMIC
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
server: cloudflare
cf-ray: 5313b599188bd46b-HAM