SSL Renewal failed

I’m using an invoicing app crater which requires to have a custom document root to $VH_ROOT/public_html/crater/public . Now when I first installed the app the SSL was working fine but now suddenly it stopped working. SSL is working fine on all the other domains and subdomains. As this is the only one with a different document root I’m assuming this is causing the issue. I tried to issue SSL from manage SSL and I get an email with failed to obtain SSL. After inspection of the access file, I found out failed the acme-challenge due to a 404 error. I even tried to manually add SSL with

  1. /root/ --issue -d -d --webroot /home/
  2. --install-cert --domain --cert-file /etc/ssl/certs/cert.pem --key-file
  3. reboot
    but with no luck. What am I doing wrong no idea please help.

Thank you

Is the domain under websites option of cyberpanel or under domains option?

It is under website options

remove the root directory name temporary then install SSL and then add again


Do you mean remove custom document root then install SSL and then again change document root. Then I have to do it every time SSL expires.

Yes, because there is no other automatic way.

Or you can purchase an yearly SSL and add in CyberPanel.

1 Like

Thank you everyone for your help. Now I at least have SSL restored. I was hoping if there is a code or maybe an acme-challenge done by DNS or something to make it automatic.

As your document root is custom, there seems currently no other way than manual intervention to renew the domain.

1 Like

Thank you for clearing that up. I really appreciate everyone’s quick responses. I wanted to mask out the links on my main post. Just don’t want any unwanted attention from hackers and spammers. Cannot find a way to edit the first post.

I have changed the domain entry on your original post.

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.