Ssl installation issue - need help badly

I updated cyberpanel to a new version of 2.3 and since then facing all the issues installing the SSL. Tried almost all the commands and even deleted and reinstalled the website multiple times…

It gets stuck at Installing SSL and never goes forward.

Attached 2 screenshots for reference.

Any help on this would be highly appreciated. :pray:

Thank you

Really cannot figure out anything.

Welcome @admn Happy you are here

Have you tried this How to fix SSL issues in CyberPanel - Docs - CyberPanel Community

Hi @josephgodwinke
Thanks for the quick revert.

I will definitely go through the video and check the solution if possible.

Meanwhile, I am already using cyber panel for close to a year now. And have close to 8-9 sites on that. And till now I was not facing any issues in setting up a new site with SSL. But suddenly after the update when I am creating the new website and (tried all PHP versions also) it gets stuck at Setting up SSL. It doesn’t move…

Post the contents of /var/log/upgradeLogs.txt i.e run the command nano /var/log/upgradeLogs.txt or vi /var/log/upgradeLogs.txt

Also post the contents of https://:8090/serverstatus/cyberCPMainLogFile just after you try to issue website ssl

permission denied. So is it related to the permissions?

Are you running a VPS or shared hosting?

VPS & pls check the error message just now when I tried to issue the SSL

Kindly try these steps Ssl installation issue - need help badly - #2 by josephgodwinke and revert back here

:+1: sounds like a plan

All the steps are done without success but the last one is pending coz not able to find the file to edit and put the code…

So pls guide…

unable to figure out this.

I checked on the SSL Checker | Free online SSL Certificate Test for your website | IONOS and here is what I got…

There’s a error in that tutorial

Make the acme-challenge directory under ols i.e mkdir -p /usr/local/lsws/Example/html/.well-known/acme-challenge/ and touch a txt file doesnt have to be hello.txt.

Sorry but couldn’t work that out… not much of a techie…