SpamAssassin causes Postfix Error 4.7.1 Service Unavailable - try again later

how to uninstall the spam assassin from cyber panel I have error:

4.7.1 Service Unavailable - try again later

Cannot send and/or receive emails.

Welcome @UniversalTelecom Happy you are here

Kindly check the forum first before raising a new topic

I tried but I can’t. can you text me on WhatsApp

@UniversalTelecom had four issues:

  1. MachineIP was different from the server ip. Changed the ip address here /etc/cyberpanel/machineIP
  2. Postfix error due to spamassassin. Deactivated spamassassin filter nano /etc/postfix/ No one is trying to debug centos 7 at its EOL.
  3. MX record issue - wrong ipv6/ipv4 address in records
  4. Change SPF records to reflect the correct server ip. SPF is enforced by the receiving email server. It should check the ip address of the sending server, domain in the email’s FROM header , and the list of permitted senders in that domain’s SPF dns records. The delivery will be failed if the sending server’s ip address isn’t in the list.

Recommended the user to change over to Ubuntu 20.04 or AlmaLinux 8.4

1 Like

Thank you, issue solved

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.