OLS Webadmin dashboard broken display (page does not set up)

Hello guys, this is not a direct Cyberpanel issue but maybe someone has any thoughts.

I get the Web Admin dashboard broken, with JS error in console (“pageSetUp is not defined”):

this is what I see:


This is on a Almalinux 8, I tried updating everything (CP, OLS, OS), but nothing helped. CP logs show nothing also.

Also, it was working fine before, it just happened suddenly (without any changes or updates). Anyone got any ideas?

Current Version:2.3
Current Commit:7d03fb6de16dfe9036aafc241e2c46e5bda64ef4
Latest Version:2.3
Lest Build:4
Latest Commit:9de252a75e62017702bd399f5014d306a1c8c7a0

Thanks in advance!

Hello @clickadmingr

Do you have an external firewall running ?

1 Like

Hi @josephgodwinke, thanks for the quick response!

Only CSF. Not Cloudflare or any other of external/3rd party firewalls.

I also just tried completely switching off CSF (because you gave me the idea) but no luck.

Run these

$ service lsws status 
## post screenshot here
$ rpm -Uvh http://rpms.litespeedtech.com/centos/litespeed-repo-1.1-1.el8.noarch.rpm
$ dnf update
$ dnf install openlitespeed
$ firewall-cmd --zone=public --permanent --add-port=7080/tcp
$ firewall-cmd --reload
$ service lsws status
1 Like

Hi again @josephgodwinke, thanks for the quick response again!

Did all that, updated Cyberpanel, rebooted, and works like a charm! Many thanks!

In detail:

  1. After verifying lsws’ status (which was running correctly, all websites on the server were running smoothly), I tried the update from the rpm and it installed correctly.
  2. Installing openlitespeed was not needed and firewall-cmd are for firewallID (not needed since there is only CSF).
  3. Not working after all that, BUT, I tried an update to Cyberpanel, rebooted, and everything worked fine!

So eventually I am going to mark your suggestion as the solution.

Could you please explain rpm line in detail and why did that help? That would be awesome.

Thanks again and best regards!

I ignored telling you this because you said you tried to do this and it did not work

Ok glad everything works well now. Ideally if you break your installtion the upgrade script should fix it you dont need to do the steps here OLS Webadmin dashboard broken display (page does not set up) - #4 by josephgodwinke

Yes I did (I’ve been having that issue for some days now and trying updating multiple times), and probably that worked after hitting your commands also, that’s why I asked what the rpm line did because probably that helped. :slight_smile:

Also I always yum updated before (not dnf) so maybe that helped also.

I just explained all the steps so anyone should not forget to update and reboot after that, apologies if that sounded like I wasn’t appreciating your help :tada:

Again thanks for everything!

(even posted your rpm line and dnf update to the solution in the OLS forum for the same issue)

The command added the proper repositiories to your AlmaLinux system

1 Like

No I just wanted to trhow in some explanation just to help the community. Some enagement would help people understand what happened just like you did a good job of explaining what you did and what the outcome was. Cheers!

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.