'NoneType' object has no attribute 'domain'

‘NoneType’ object has no attribute ‘domain’ EMAIL FORWARDING

Please provide these details → Bug Report Template - Bug Report - CyberPanel Community

Also please provide exact steps to reproduce the problem.

I have the same issue. did you manage to get this resolved? CNAME from domainA.com to DomainB.com. Both added to cyberpanel. Created ABC@domainA.com and ABC@domainB.com. Forwarding for ABC@domainA.com does not work. It brings up this error message.

Kindly upgrade your CyberPanel and see if you can reproduce the issue

Having the same issue …

when email forwarding from email1@child-domain.com to email2@child-domain.com

and I am running latest Cyberpanel 2.1b2

This error definitely seems related to child domains

While deleting the child domain email address We face this issue "cannot delete email account. Error message: ‘NoneType’ object has no attribute ‘domain’. "

Has this been resolved? Because I’m getting the same error when trying to delete a mail (of a domain, not a website)

Same error I get when I click Fix button of " SSL for email is not configured properly, you may get Self-Signed error on mail clients such as Outlook and Thunderbird. More details here."

Welcome @sergiustatache Happy New Year

Try this if it fixes your issues

See here it worked for some

It didn’t work. I tried something else. I deleted the domain and re-added it, but now when I list Emails and click the Fix now button I get a new error “Websites matching query does not exist.” Any idea to solve this?

See this Can't remove domain- domain after remove still in panel - #6 by aw11 I advice you create your own topic for this