Many WordPress Issues on OpenLiteSpeed with Cyberpanel

I am using Litespeed Server with WordPress and Cyberpanel. I am facing a lot of issues with WordPress.

  1. Recently Admin login was redirecting to the Admin login page and not to the dashboard.
  2. I can’t change anything on the backend if I was logged in. If i try to disable a plugin or change Litespeed plugin settings it won’t be done.

In the end, I was logged in but didn’t have permission to do anything.

  1. Server will suddenly not respond without any changes. Like it will work for 10-12 hrs without any issue but after it won’t respond.

I am using AWS and a 8-core fast hosting. Every time I have to just restart the server to fix all of this.

Restarting the server every day is not a solution. Can you help me in solving this issue?

Check your WordPress and server error logs

I don’t think, It’s just the issue of WordPress.

Bcoz when server is behaving wierdly I can’t even login to the Litespeed admin panel. It gives an error of Invalid credentials. And after a server restart, the same credentials work!.

Anyway, I don’t understand error logs very properly. Can you help?

There’s a lot of great information in the forum if you use the search tool.

Try the files/methods listed here and post your results.

I am attaching a link to the Google Drive folder which has all the log files.
In some log files, you will find a website URL Cyberpaneltest. ml. Ignore it as it was a clone and I deleted it. And I replaced my domain with example .com.

Link - Logs - Google Drive

Seems like it might be a plugin conflict with php8. Try php 7.4.

Might also be something with the htaccess rewrite rules… Try creating a new site and copy the htaccess file to this site to see what happens.

Thank you for your help!
I am now using PHP 7.4 on my website.

I thought the same. That’s why I deleted the old file and created a new .htaccess file. But will still try the suggested method to debug.

The same things happened just 5 min before. The server stopped responding. And nothing was working and just cached version was visible. We can’t log in to any system.

Please check the error logs
2022-05-26 17:32:56.012712 [NOTICE] [20614] [172.70.218.209:14744:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:56.012725 [NOTICE] [20614] [172.70.188.87:30146:HTTP2-3#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:57.016441 [NOTICE] [20614] [172.70.189.60:23872:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:58.092400 [NOTICE] [20614] [162.158.48.109:41882:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:59.094557 [NOTICE] [20614] [172.70.189.80:20518:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:59.094586 [NOTICE] [20614] [172.70.218.153:9476:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:59.094596 [NOTICE] [20614] [162.158.227.133:13268:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:32:59.094607 [NOTICE] [20614] [172.69.239.161:42358:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:01.020749 [NOTICE] [20614] [162.158.31.187:49086:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:01.020816 [NOTICE] [20614] [172.70.246.17:16514:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:02.001378 [NOTICE] [20614] [172.70.218.153:9416:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:02.001408 [NOTICE] [20614] [162.158.235.66:33408:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:03.048868 [NOTICE] [20614] [172.70.219.12:13474:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:06.069176 [NOTICE] [20614] [172.70.188.211:40576:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:06.069204 [NOTICE] [20614] [172.70.218.209:14744:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:06.069214 [NOTICE] [20614] [172.70.188.87:30146:HTTP2-3#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:07.036262 [NOTICE] [20614] [172.70.189.60:23872:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:08.012411 [NOTICE] [20614] [162.158.48.109:41882:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:09.004735 [NOTICE] [20614] [172.70.189.80:20518:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:09.004760 [NOTICE] [20614] [172.70.218.153:9476:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:09.004770 [NOTICE] [20614] [162.158.227.133:13268:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:09.004779 [NOTICE] [20614] [172.69.239.161:42358:HTTP2-1#example.com] No request delivery notification has been received from LSAPI application, possible dead lock.
2022-05-26 17:33:16.018509 [NOTICE] [20614] [172.70.188.87:30146:HTTP2-3#example.com] ExtConn timed out while processing.
2022-05-26 17:34:47.553338 [NOTICE] [20614] [172.70.219.62:38010:HTTP2-1#example.com] [STDERR] The Automattic\WooCommerce\Admin\API\Options::get_options function is deprecated since version 3.1.
2022-05-26 17:34:47.576466 [NOTICE] [20614] [172.70.219.62:38010:HTTP2-1#example.com] [STDERR] The Automattic\WooCommerce\Admin\API\Options::get_options function is deprecated since version 3.1.

Is this at a specific interval, i.e. every 12 hours, or is it at random times?

It’s happening every 5-6 hrs and I can’t say it’s a fixed interval bcoz sometimes it’s random. I have to restart to fix it. Idk what to do?

try upgrading cyberpanel? 02 - Upgrading CyberPanel - 01 - Install/Upgrade - Docs - CyberPanel Community

Or try a fresh VPS server just to test it out. Just deploy it with ubuntu 20.04 and then install CyberPanel and OLS with this Latest install topics - CyberPanel Community

There’s lots of people who have reported these errors elsewhere. Its worth checking their comments and proposed solutions

I recently upgraded Cyberpanel and Openlitespeed was upgraded with it.
I am using the latest version and the Ubuntu version is 20.04.

Also, I am constantly trying different stuff mentioned in different forums but none of them is working for me.
Your google link seems special. I really got a lot of articles on this. I searched on google previously but didn’t receive much help.

Disabling GZip compression fixed all issues. The alternate fix can be to increase your temporary folder size. I was using Cloudflare so I enabled compression on the Cloudflare.

Also, update the value of CPU Affinity to 1. IDK if this solved it but you can try both.

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.

There is no actual need to disable gzip as I use Aws too for my servers and use cyberpanel in it.
There might be something more than what you have described here. Maybe some backup operations you scheduled with gzip output?