Lsphp74, lsphp8.0 Zip Extension Issues With Ubuntu 20.04

Hi there, there is no zip extension on cyberpanel all of php versions i need them for 7.4 and 8.0 and i have checked manually but
they are not there
also zip not here: /usr/local/lsws/lsphp74/lib/php/20190902

please check the screenshot

Update your cyberpanel there was some issues unzipping on file manager earlier, maybe it’s something related to this.

No, I mean Zip PHP extension not zip extraction

Try sudo apt install lsphp80* and sudo apt install lsphp74* those commands install all available extensions

I already did only install few but not installed i also tried installing it byitself and still not showing

Hi there!
I’m having same problem. I need zip extension for php8 and php8.1
Did ou find any solution? (CentOS7)

I remember on openlitespeed you can install these modules manually via terminal if hosting provider allows for CentOs it is possible.

yum install lsphp73-zip

For debian-based os like ubuntu as far as I have tested since I started using CyberP never works apt-cache search lsphp81* you can only install whatever the list shows.

hello @josephgodwinke thanks for your answer but I need it for php8 and php8.1 at CentOS7

Lookup the modules you would like here and use the method I stated in my previous comment

I had this same problem,

Follow my tutorial here: Compiling php tutorial

My tutorial is php 8.1 but the same goes for php 8.0, just use the appropriate versions you are trying to install