Local SMTP server not working

I am unable to get the SMTP server working, I need the SMTP server for one of my application but it doesn’t work at all, I am using almalinux. Spark mail too doesn’t discover my email account and I am also not able to use the email on my gmail app.

  1. your cyberpanel version
  2. any log ?
  3. domain ?
  4. vps provider

Cyberpanel is in the latest version v2.3.1
No logs available (actually i don’t know how to get the logs regarding smtp)
Domain- sweetcashoffer. com
Provider- rackneard

your mail server domain should not behind the cloudflare proxy

I turned off the proxy and tried but still no connection, can you also tell me the SMTP username and password? is it the same as the email created?

open https://domain.tld:8090/email/listEmails


try to use webmail first to test everything working

Thanks, will try it. Also if I have multiple domains will the smtp server for each domain be different or the same? I am able to receive mails from Gmail but my mails do not reach the mailbox of Gmail

only 1 mail server
also if you want to set unique (and this is good for spamscore) you will need to bypass the mail.domain.tld from cloudflare