Listener for _default_ is not available

I have a problem with the virtual host. I have a domain and subdomain for Cyberpanel. For the domain everything is fine, but the vhost for the subdomain shows that the default listener is unavailable.

I can’t edit httpd.conf because it is generated automatically. Can I configure it manually to fix the problem?

2023-01-02 12:22:59.485588 [INFO] [992] [T0] Processing config file: /usr/local/lsws/conf/vhosts/EXAMPLE.COM/vhost.conf

2023-01-02 12:22:59.485588 [INFO] [992] [T0] Processing config file: /usr/local/lsws/conf/vhosts/EXAMPLE.COM/vhost.conf

2023-01-02 12:22:59.486403 [INFO] [992] [T0] Processing config file: /usr/local/lsws/conf/vhosts/panel.EXAMPLE.COM/vhost.conf

2023-01-02 12:22:59.486403 [INFO] [992] [T0] Processing config file: /usr/local/lsws/conf/vhosts/panel.EXAMPLE.COM/vhost.conf

2023-01-02 12:22:59.495216 [ERROR] [992] [T0] [/usr/local/lsws/conf/vhosts/panel.EXAMPLE.COM/vhost.conf:34] Listener for _default_ is not available.

2023-01-02 12:22:59.495216 [ERROR] [992] [T0] [/usr/local/lsws/conf/vhosts/panel.EXAMPLE.COM/vhost.conf:34] Listener for _default_ is not available.

[Mon Jan 2 12:22:59 2023] [notice] Finish reading Apache configuration, server configured -- resuming normal operations

Ubuntu 20.4 | LSWS | Cyberpanel 2.3 Build 2.

Hi there,

Did you solve this issue - I’m currently facing the same and I can’t launch a web site with the “Test Domain” feature enabled in CyberPanel :frowning:

Please let me know :slight_smile: Thank you so much!

I haven’t resolved the issue yet, but I have reported the bug to the CyberPanel team. They should fix it soon.

Yes they told me the same the other day - but I doubt when “soon” will be :wink: fingers crossed.

I had the same problem, I saved the situation by adding the missing domains back to the httpd.conf file

I specifically state that this happened after the last update of cyberpanel.

This problem has existed for many years, but it is not critical. I have all domains in my httpd.conf file.

I just don’t like seeing errors that shouldn’t be there. This definitely needs to be fixed.

Can someone explain how this fix is done? I am having this problem. Another site said to remove Apache since cyberpanel uses litespeed. I attempted this and now Power DNS is stopped. The system seems to be reading sites from an alternate directory instead of the correct site directory.