LetsEncrypt SSL not working - failed to obtain SSL

Using OpenLiteSpeed with CyberPanel v2.0.1 on Digital Ocean and trying to issue a LetsEncrypt certificate for a website but only a self-signed certificate is issued. So the https url will only load the site if I accept the browser security warning which adds an exception.

I followed the instructions at https://cyberpanel.net/docs/how-to-fix-ssl-issues-in-cyberpanel/ and I’ve checked that ModSecurity is not installed. I ran the debug and in the CP log I now see:

Failed to obtain SSL for: mydomain.com and: www.mydomain.com
Trying to obtain SSL for: mydomain.com
Failed to obtain SSL, issuing self-signed SSL for: mydomain.com
Self signed SSL issued for mydomain.com

In /etc/letsencrypt/live/mydomain.com/ files cert.pem, fullchain.pem and privkey.pem do exist.

What should I check next?

Please upgrade your CyberPanel and try again.

1 Like

The following command solved the upgrade errors:

apt install default-libmysqlclient-dev

Now running CP v2.1.1, re-issued SSL and the LetsEncrypt SSL is now working!

Thank you Usman for this great control panel and for your fast support!

1 Like

Hi @usmannasir1
firts I got error 500 and after runing upgrade I got this:
ERROR: Could not install packages due to an OSError: [Errno 28] No space left on device

Clearly seems that there will be no space mostly tmp is full. Please share df output @av_admin

1 Like