Issues with uploading files to /home/

So first off, I am testing CyberPanel on my network and it has been going pretty well.

I uploaded a Duplicator Pro copy of a smaller website that was 432MBs in size and was able to quickly restore the site saw that everything worked as it should with OpenLightSpeed as the site was built on Apache2.

I then tried to upload one of our member sites that is quite a bit bigger, 3GBs in size, and I ran into issues that I can not fix. The file manager says “can not be uploaded, Error message:” I also do not see anything in the error log. I updated php.ini as well as the PHP settings in the panel both to accept 8092M and still nothing.

Just so you’re on the same page as me, I set up an FTP user account and tried to log in. I’ve been hitting a wall as it wants to bypass my router even though I told it to resolve the address to my Ubuntu server that is being spun up by ESX 7. Instead, it is accessing one of my static ISP addresses, DNS in the Cyberpanel has the same static as its settings so maybe that is the problem. I don’t own the domain I am just telling my router that it is a local address it should resolve to and for HTTP and https it works well. Manually putting in the IP address of the host fails as well so I’m thinking there is an issue somewhere else unless CyberPanel uses the URL only for its FTP and not the actual IP Address of the server.

If I update DNS to its actual local address on the CyberPanel VM and ping or dig I get the valid IP local address. In both cases I can log in, the username is good and the password is good but it fails to list the directory with a " 257 “/” is your current location ", meaning it didn’t respond cause it didn’t find a directory.

I’m thinking of using a domain I don’t use on a DigitalOcean server to see if these issues resolve themself. I’m still stumped on why I can’t upload the 3GB file from a backup I want to restore from the web interface for the domain that is configured.

I would like to have a local site that is a copy of my public site so I can develop in a private environment to test applications and such. So far apache has worked well but I’d like to use OpenSpeedLite and a panel if at all possible. Does anyone have any pointers as to why FTP or the file manager is not working correctly?