Issue with python MarkupSafe module on install

Provider: Virtual Machine under VMWare Workstation 15

Virtualization Type: VMWare

System: Centos 7.7 & Ubuntu 18.04

Installation option:

OLS or Enterprise?
Installing from official server or mirror server?
Install Memcached extension for PHP?
Install LiteSpeed Memcached?
Install Memcached?
Install Redis extension for PHP?
Install Redis?


When I try to install CyberPanel under VMWare minimal CentOS 7 or Ubuntu 18.04 basic server, install fails. On CentOS 7 it show following error message

ERROR: Command errored out with exit status 1:
 command: /usr/local/CyberPanel/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-fg156h2x/MarkupSafe/'"'"'; __file__='"'"'/tmp/pip-install-fg156h2x/MarkupSafe/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\\r\

‘"’"’, ‘"’"’
‘"’"’);f.close();exec(compile(code, file, ‘"’"‘exec’"’"’))’ egg_info --egg-base /tmp/pip-install-fg156h2x/MarkupSafe/pip-egg-info
cwd: /tmp/pip-install-fg156h2x/MarkupSafe/
Complete output (5 lines):
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-install-fg156h2x/MarkupSafe/”, line 3, in
from setuptools import setup, Extension, Feature
ImportError: cannot import name ‘Feature’
ERROR: Command errored out with exit status 1: python egg_info Check the logs for full command output.

command failed, exiting…

I tried re-install on clean Ubuntu 18.04 VM but same issue occurred

I don’t think this is caused by VMWare enviroment but I might be wrong.

Soon after I’ve posted this someone else also encountered same issue.

I’ve tried to increase MarkupSafe module version in requirements.txt one at the time.
When I’ve got to 0.19 command /usr/local/CyberPanel/bin/pip3 install --ignore-installed -r requirements.txt completes successfully.

I am guessing the script could be uploaded with a bug, I am going to try a mirror

fixed , please try again

Traceback (most recent call last):
File “”, line 2388, in
File “”, line 2342, in main
File “”, line 2197, in installAcme, self.distro, command, command, 1, 0, os.EX_OSERR)
File “”, line 207, in call
res =
File “/usr/lib64/python3.6/”, line 287, in call
with Popen(*popenargs, **kwargs) as p:
File “/usr/lib64/python3.6/”, line 729, in init
restore_signals, start_new_session)
File “/usr/lib64/python3.6/”, line 1364, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘/root/’: ‘/root/’
Oops, something went wrong…