install error

centos7 and centos8

yum -y update

dnf -y update

selinux disabled

install nano and wget

reboot

sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)

http://prntscr.com/vgazfk

ERROR: Double requirement given: cffi==1.14.1 from file:///usr/local/pip-packs/cffi-1.14.1-cp36-cp36m-manylinux1_x86_64.whl (already in cffi==1.11.5 from file:///usr/local/pip-packs/cffi-1.11.5-cp36-cp36m-manylinux1_x86_64.whl, name=‘cffi’)

Confirmed, happens in Ubuntu 18.04 as well.

Confirmed it happened with Centos 7 and 8 and Ubunto 18

I just registered to make a reply so that I can help those who have the same problem like me which cost me 4 hours of trial and error.

This is what you will do. (My client have CENTOS8 but it will work for you as well)

First, you need to upgrade. WHAT/.? We even haven’t successfully installed because of the error “ERROR: Double requirement given: cffi==1.14.1” always at the end!!!

Relax. There’s a prob with their installation list.

This is the very first thing you do. Type this command in the shell.

sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)

If it ask for a branch version just press enter then the process begin… BUT in the end you will get an error!!! and it quits.

CONGRATS!!!

This is your moment!!! This is your time!!! It’s showtime!

Now, type this command in the shell:

sh <(curl https://cyberpanel.net/install.sh || wget -O - https://cyberpanel.net/install.sh)

and wait for it to successfully finished!

GOOD JOB!

VERY GOOD JOB jabez2317 !!

I had found a dirty workaround by grabbing an old cyberpanel-pip.zip from a server installed last week but without being 100% sure nothing else will be broken… (tried to post that but didn’t show in the thread)

Yours seems pretty good !

Update : on a fresh install I had to do “dnf install wget” before the preupgrade script because it has a wget command inside