Increase LSAPI_CHILDREN

Hello,

I see the following in my stderr.log hundreds of times.

[7768] Reached max children process limit: 5, extra: 1, current: 6, busy: 6, please increase LSAPI_CHILDREN.

so I would like to increase my LSAPI_CHILDREN.

My website’s vHost conf doesn’t contain any line with LSAPI_CHILDREN, is there any other location I can check?

PS: I’m using CyberPanel Enterprise 1.8.1

Thanks,
George

Hello

If on the command line you do

cat /usr/local/lsws/conf/httpd_config.xml | grep LSAPI_CHILDREN

You will see value of PHP_LSAPI_CHILDREN. You can open this file via nano or vi editor and edit this parameter and restart LiteSpeed, you can also do this via Webadmin. An example of output of the above command is

cat /usr/local/lsws/conf/httpd_config.xml | grep LSAPI_CHILDREN
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>
      <env>PHP_LSAPI_CHILDREN=35</env>

there is also a parameter

phpSuExecMaxConn>5</phpSuExecMaxCon

in httpd_config.xml

need to change 5 to higher number.

Thanks, it was phpSuExecMaxConn after all :wink: