I got 1 error like this. can't access website + delete files : permission error


$ chmod -R 777 /home/mycoolwebsite/public_html
1 Like

it runs a series like this
Website still can’t access


## change the user ownership of all files within the WWW folder
$ chown -R aloba1691:aloba1691 /home/mycoolwebsite/public_html
$ chmod -R 777 /home/mycoolwebsite/public_html

assumption is you are a sudo user or root

1 Like

I don’t understand why they don’t work. And when I run that command, it’s like the image below

Let’s clear/unset immutability attribute

# a flag lists all contents, i flag for files which cannot be modified (immutable)
$ chattr -R -ia /home/mycoolwebsite/public_html

I was able to delete the files using the above command
But I don’t understand why my website is still not accessible

when i check my folder. I feel like I’m missing something


I use this command and the output looks like this:
service lsws restart

Can you click Fix Permissions and see if it works.

Which version of cyberpanel are you using ?

I can edit its files
and this is my version

Check if immutable directory

$ lsattr /home/mycoolwebsite/public_html

immutable files will look like this

----i--------e-- /home/mycoolwebsite/public_html/wp-config.php
1 Like

And this is the result

help help :smiling_face_with_tear:

Seems no files are immutable but just to be sure

To remove the immutable flag, we can only use chattr with the - operator:

sudo chattr -R -i  /home/mycoolwebsite/public_html
1 Like

website still not working

Try delete a file what is the result

Psst I made a mistake on the command here I got 1 error like this. can't access website + delete files : permission error - #16 by josephgodwinke try again

1 Like

I tried deleting the index.php file.
But the website is still not working

Deactivate your CDN, or use VPN instead

I checked . And the domain name is Dns to the correct server with my IP

I have successfully fixed it.
Thank you for your support
1 wish you good day

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.