How to switch Self-Signed SSL to Let's Encrypt?

So I have two websites on two different Hetzer Cloud servers. One of them has SSL with Let’s Encrypt. I had no issue getting that setup. The second website I cannot seem to get Let’s Encrypt on it, the domain is stuck with Self-Signed SSL.

I have gone to the SSL sections and issue them for my domain, but it still won’t present me with Let’s Encrypt.

Screenshot 2022-08-28 at 22-32-30 shipaxxess.com - CyberPanel

Any suggestions on how to properly setup SSL from CP so that Let’s Encrypt is working without the usage of CloudFlare?

Log:

[08.29.2022_13-10-42] Failed to obtain SSL for: shipaxxess.com and: www.shipaxxess.com
[08.29.2022_13-10-42] /root/.acme.sh/acme.sh --issue -d shipaxxess.com --cert-file /etc/letsencrypt/live/shipaxxess.com/cert.pem --key-file /etc/letsencrypt/live/shipaxxess.com/privkey.pem --fullchain-file /etc/letsencrypt/live/shipaxxess.com/fullchain.pem -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt
[08.29.2022_13-10-42] Failed to obtain SSL, issuing self-signed SSL for: shipaxxess.com
[08.29.2022_13-10-42] {'email@shipaxxess.com': (554, b'5.7.1 <email@shipaxxess.com>: Relay access denied')}
[08.29.2022_13-10-42] Self signed SSL issued for shipaxxess.com.
[08.29.2022_13-11-00] 'tempPath' [backupStatus]
[08.29.2022_13-12-01] Status Code: 404 for: http://www.shipaxxess.com/.well-known/acme-challenge/shipaxxess.com. Error: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.18.0 (Ubuntu)</center>
</body>
</html>

[08.29.2022_13-12-01] Status Code: 404 for: http://shipaxxess.com/.well-known/acme-challenge/shipaxxess.com. Error: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.18.0 (Ubuntu)</center>
</body>
</html>

[08.29.2022_13-12-02] /root/.acme.sh/acme.sh --issue -d shipaxxess.com -d www.shipaxxess.com --cert-file /etc/letsencrypt/live/shipaxxess.com/cert.pem --key-file /etc/letsencrypt/live/shipaxxess.com/privkey.pem --fullchain-file /etc/letsencrypt/live/shipaxxess.com/fullchain.pem -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt
[08.29.2022_13-12-02] Failed to obtain SSL for: shipaxxess.com and: www.shipaxxess.com
[08.29.2022_13-12-02] /root/.acme.sh/acme.sh --issue -d shipaxxess.com --cert-file /etc/letsencrypt/live/shipaxxess.com/cert.pem --key-file /etc/letsencrypt/live/shipaxxess.com/privkey.pem --fullchain-file /etc/letsencrypt/live/shipaxxess.com/fullchain.pem -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt
[08.29.2022_13-12-02] Failed to obtain SSL, issuing self-signed SSL for: shipaxxess.com
[08.29.2022_13-12-02] {'pwz2k@hotmail.com': (554, b'5.7.1 <pwz2k@hotmail.com>: Relay access denied')}
[08.29.2022_13-12-02] Self signed SSL issued for shipaxxess.com.
[08.29.2022_13-17-52] Status Code: 404 for: http://www.shipaxxess.com/.well-known/acme-challenge/shipaxxess.com. Error: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.18.0 (Ubuntu)</center>
</body>
</html>

[08.29.2022_13-17-52] Status Code: 404 for: http://shipaxxess.com/.well-known/acme-challenge/shipaxxess.com. Error: <html>
<head><title>404 Not Found</title></head>
<body>
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.18.0 (Ubuntu)</center>
</body>
</html>

[08.29.2022_13-17-53] /root/.acme.sh/acme.sh --issue -d shipaxxess.com -d www.shipaxxess.com --cert-file /etc/letsencrypt/live/shipaxxess.com/cert.pem --key-file /etc/letsencrypt/live/shipaxxess.com/privkey.pem --fullchain-file /etc/letsencrypt/live/shipaxxess.com/fullchain.pem -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt
[08.29.2022_13-17-53] Failed to obtain SSL for: shipaxxess.com and: www.shipaxxess.com
[08.29.2022_13-17-53] /root/.acme.sh/acme.sh --issue -d shipaxxess.com --cert-file /etc/letsencrypt/live/shipaxxess.com/cert.pem --key-file /etc/letsencrypt/live/shipaxxess.com/privkey.pem --fullchain-file /etc/letsencrypt/live/shipaxxess.com/fullchain.pem -w /usr/local/lsws/Example/html -k ec-256 --force --server letsencrypt
[08.29.2022_13-17-53] Failed to obtain SSL, issuing self-signed SSL for: shipaxxess.com
[08.29.2022_13-17-53] {'pwz2k@hotmail.com': (554, b'5.7.1 <pwz2k@hotmail.com>: Relay access denied')}
[08.29.2022_13-17-53] Self signed SSL issued for shipaxxess.com.

Check if you have acme-challenge context on that website config.
If you don’t, search here on the forum, i made a script to fix it.

If you have, try the command on this topic after:
https://community.cyberpanel.net/t/my-ssl-is-self-signed/36608/15

You can view output here after running that command log.txt · GitHub

404, then it must be acme-challenge missing

I could’ve sworn I installed that before, but just incase I didn’t I reinstalled it. 404 error is still present. LOGS.TXT · GitHub

The folder I gave for the -w value may not the same as the nginx root folder. How do I find the root folder just to double check? Maybe that’s why the 404 error is showing.

-w /usr/local/lsws/Example/html 

The command I sent was for cyberpanel.
You are using nginx, that’s not cyberpanel related.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.