How to have my django app accessible from port 80 instead of 8000?


I would like to access my Django server from MYSITE instead of from MYSITE:8000, I have seen that one of the solution was to set up a reverse proxy.

But I really don’t know how to do this (my server is using Litespeed). Here is the Vhost.conf file:

docRoot                   /home/MYSITE/tests/backend
vhDomain                  $VH_NAME
vhAliases                 www.$VH_NAME
adminEmails               ...
enableGzip                1
enableIpGeo               1

index  {
  useServer               0
  indexFiles              index.php, index.html

errorlog $VH_ROOT/logs/MYSITE.error_log {
  useServer               0
  logLevel                WARN
  rollingSize             10M

accesslog $VH_ROOT/logs/MYSITE.access_log {
  useServer               0
  logFormat               "%h %l %u %t "%r" %>s %b "%{Referer}i" "%{User-Agent}i""
  logHeaders              5
  rollingSize             10M
  keepDays                10  
  compressArchive         1

phpIniOverride  {


module cache {
 storagePath /usr/local/lsws/cachedata/$VH_NAME

scripthandler  {
  add                     lsapi:USER91427768 php

extprocessor aymer91427768 {
  type                    lsapi
  address                 UDS://tmp/lshttpd/USER91427768.sock
  maxConns                10
  env                     LSAPI_CHILDREN=10
  initTimeout             60
  retryTimeout            0
  persistConn             1
  pcKeepAliveTimeout      1
  respBuffer              0
  autoStart               1
  path                    /usr/local/lsws/lsphp74/bin/lsphp
  extUser                 USER9142
  extGroup                USER9142
  memSoftLimit            2047M
  memHardLimit            2047M
  procSoftLimit           400
  procHardLimit           500

rewrite  {
  enable                  1
  autoLoadHtaccess        1

context / {
  type                    appserver
  location                /home/MYSITE/tests/backend
  binPath                 /usr/local/lsws/fcgi-bin/lswsgi
  appType                 wsgi
  startupFile             cyberpanel/
  envType                 1
  env                     LS_PYTHONBIN=/home/MYSITE/tests/myenv/bin/python
  env                     PYTHONHOME=/home/MYSITE/tests/myenv/

Any idea on what should I change on this file ? Should I change some other file as well ?


Check this, maybe it might help.