High CPU Usage, 4CPU 8GB RAM

Hello @SuperPSX

https://community.cyberpanel.net/uploads/default/original/2X/4/4472a486238b11b59a67cb5d84a031b161700b11.png

It seems you have no cache plugins running

I’m using lightspeed cache

For some reason your wordpress installation is comlaining that it cannot read these headers

X-LiteSpeed-Cache: miss
X-LiteSpeed-Cache-Control:public,max-age=1800
X-LiteSpeed-Tag:B1_F,B1_ 

Can you confirm the homepage is cacheable. maybe your homepage is a non-cacheable page. To confirm use developer tools in your browser or better yet use https://check.lscache.io/.

Post a screenshot here

No issue here maybe wordpress false positive. Ignore for now unless you can confirm from normal use that caching doesnt work

This error keeps showing on Site Health. I had to restart my server because few minutes ago my website was down. I don’t understand what’s going on.

Ignoring that issue. Post your main log file here when you restart your server I see what is causing your website to crash.

Plus I dont recommend my clients to use LSMCD with LSCACHE I have never made it work but normal memcached works perfectly. That is from experience. Plus you can simple optimize your site using this tutorial forget the extras How to optimize WordPress site using LSCache Plugin - CyberHosting

This is same tutorial I give all my users

Thank you for the tutorial. This is something wrong with LightSpeed Cache Plugin settings. Also, I’ve no idea why LightSpeed Cache plugin generates avatars


so many avatar images “wp-content/litespeed/avatar”

Those are cached avatars. That is what caching plugins do. Generate cached files and store them in a CDN or on your server

Do a clean install of that plugin

Clear cache first

Go to plugin page → click “deactivate” then “remove ”

You can verify by content /wp-content/plugins/ you should no longer see litespeed-cache directory , and if you do , manually delete it

Maybe cache issue from my OpenLight Speed. Can you guide how to setup, Server Configuration “OpenLight Speed”?

Wrong place buddy check this tutorial Enable LSCache through rewrite rules when LiteSpeed Cache Plugin not available – OpenLiteSpeed

Simple .htaccess would look like:

<IfModule LiteSpeed>
RewriteEngine On
RewriteRule (.*\.php)?$ - [E=cache-control:max-age=120]
</IfModule>

Then setup a way to purge the cache:

$ crontab -e
$ */10 * * * * root find /virtualhost/cache/root/directory/ -type f -mmin +8 -delete 2>/dev/null

This cron job deletes cached files that are more than 8 minutes old every 10 minutes. Since the cache TTL is set at 120 seconds (2 minutes), it is safe to delete these files as they are way past their TTL.

1 Like

I can install PHP extension (Memcache and Redis), Should I uninstall Redis extension and install Memcache?

Use one so install what you need only. Personally i prefer redis.