Google Drive CyberPanel Bug Help


I’m trying to add a Google Drive Backup account, but the option is redirecting me to instead.

I have tried to clear cache, reinstall CyberPanel but it’s still not working.

Kindly assist.

same here…
As I found in the docs, there used to be a problem:

Troubleshooting redirection from platform to cloud
We have recently shifted the support URL from to If you are being redirected and unable to setup, please upgrade Cyberpanel and try again

However, this was not fixed for me after an the upgrade :expressionless:

1 Like

hello, im having the same problem.

“error_message”: “No module named ‘google’”,

can we please get a response on this?

@deewinc @j2ee
FYI… I use the following command now (with the combination of cronjob):

cyberpanel createBackup --domainName

The backups will be created in the default location:

From there I upload the backups manually to google drive.
I can recommand this guide:

MAYBE this issue will be fixed eventually from cyberpanel…


we need an internal solution in cyberpanel

Solution is internal, I’ve explained couple of times that google oauth need a valid domain and that process require you to move to, after that process is all in CyberPanel.

1 Like

This was not clear in the docs , I appreciate your work and help .