Generating many error logs about rewrite

Hello, I today noticed that my error logs generating many data. for rewrite. How i can resolve it?

2022-07-23 16:30:24.471728 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] add ENV: ‘HTTP_AUTHORIZATION:’
2022-07-23 16:30:24.471753 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:24.471763 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^index.php$’, result: -1
2022-07-23 16:30:24.471772 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^en/wp-login.php’, result: -1
2022-07-23 16:30:24.471780 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^lt/wp-login.php’, result: -1
2022-07-23 16:30:24.471790 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘.’, result: 1
2022-07-23 16:30:24.471847 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] stat( /home/abiti.lt/public_html/produkto-zyma ) failed
2022-07-23 16:30:24.471867 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] stat( /home/abiti.lt/public_html/produkto-zyma ) failed
2022-07-23 16:30:24.471883 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] Source URI: ‘produkto-zyma/pilki-dzinsai/’ => Result URI: ‘/index.php’
2022-07-23 16:30:24.471897 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] Last Rule, stop!
2022-07-23 16:30:24.471909 [INFO] [57587] [172.70.135.166:48252:HTTP2-1#abiti.lt] [REWRITE] apply cache-control: ‘no-autoflush’.
2022-07-23 16:30:27.447102 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] strip base: ‘/’ from URI: ‘/produkto-zyma/pilki-dzinsai/’
2022-07-23 16:30:27.447189 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^/?(.)', result: 2
2022-07-23 16:30:27.447209 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Cond: Compare ‘on’ with pattern ‘on’, result: 0
2022-07-23 16:30:27.447224 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern '.
’, result: 1
2022-07-23 16:30:27.447241 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447256 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘.litespeed_conf.dat’, result: -1
2022-07-23 16:30:27.447270 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘.', result: 1
2022-07-23 16:30:27.447290 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Cond: Match ‘Mozilla/5.0 (compatible; SemrushBot/7~bl; +http://www.semrush.com/bot.html)’ with pattern ‘Mobile|Android|Silk/|Kindle|BlackBerry|Opera\ Mini|Opera\ Mobi’, result: -1
2022-07-23 16:30:27.447299 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern 'wp-content/.
/[^/](responsive|css|js|dynamic|loader|fonts).php’, result: -1
2022-07-23 16:30:27.447307 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘.?’, result: 1
2022-07-23 16:30:27.447317 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] set cache vary on: ‘,wp-postpass_dc0b5078bedd01200fbf729e7d76bd4f’
2022-07-23 16:30:27.447343 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] add ENV: ‘Cache-Vary:,wp-postpass_dc0b5078bedd01200fbf729e7d76bd4f’
2022-07-23 16:30:27.447351 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447358 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘favicon.ico$’, result: -1
2022-07-23 16:30:27.447367 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern '.
’, result: 1
2022-07-23 16:30:27.447377 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Cond: Match ‘text/html, application/rss+xml, application/atom+xml, text/xml, text/rss+xml, application/xhtml+xml’ with pattern ‘image/webp’, result: -1
2022-07-23 16:30:27.447415 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Cond: Match ‘Mozilla/5.0 (compatible; SemrushBot/7~bl; +http://www.semrush.com/bot.html)’ with pattern ‘Page Speed’, result: -1
2022-07-23 16:30:27.447424 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘.*’, result: 1
2022-07-23 16:30:27.447432 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Cond: Match ‘Mozilla/5.0 (compatible; SemrushBot/7~bl; +http://www.semrush.com/bot.html)’ with pattern ‘iPhone.*Version/(\d{2}).Safari’, result: -1
2022-07-23 16:30:27.447441 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^’, result: 1
2022-07-23 16:30:27.447470 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447479 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^’, result: 1
2022-07-23 16:30:27.447489 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447496 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^’, result: 1
2022-07-23 16:30:27.447505 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447513 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^’, result: 1
2022-07-23 16:30:27.447522 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447530 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern '.
’, result: 1
2022-07-23 16:30:27.447540 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] add ENV: ‘HTTP_AUTHORIZATION:’
2022-07-23 16:30:27.447547 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] No substition
2022-07-23 16:30:27.447555 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^index.php$’, result: -1
2022-07-23 16:30:27.447563 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^en/wp-login.php’, result: -1
2022-07-23 16:30:27.447571 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘^lt/wp-login.php’, result: -1
2022-07-23 16:30:27.447579 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Rule: Match ‘produkto-zyma/pilki-dzinsai/’ with pattern ‘.’, result: 1
2022-07-23 16:30:27.447610 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] stat( /home/abiti.lt/public_html/produkto-zyma ) failed
2022-07-23 16:30:27.447657 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] stat( /home/abiti.lt/public_html/produkto-zyma ) failed
2022-07-23 16:30:27.447666 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Source URI: ‘produkto-zyma/pilki-dzinsai/’ => Result URI: ‘/index.php’
2022-07-23 16:30:27.447675 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] Last Rule, stop!
2022-07-23 16:30:27.447683 [INFO] [57585] [172.70.135.76:64448:HTTP2-1#abiti.lt] [REWRITE] apply cache-control: ‘no-autoflush’.

This is not an error, this is info.

@ayobpro thank you

still, that’s some weird rewrite info, looks like apache2 rewrite rules used in openlitespeed.

I don’t understand that I am newbie in this :slight_smile:

this info basically say there’s a bunch of rewrite rules that fails. That’s why there’s the big [REWRITE] on each line, and a bunch of failed and result -1. Usually it’s some wordpress plugins adding .htaccess rules that doesn’t make sense. You can post the .htaccess

No problem, I am using LSCache plugin wit openlitespeed server. Only for this post I remove in the end sign > after IfModule. This cooment place don’t let show ifmodule :slight_smile:

Rewrite Rules Added by CyberPanel Rewrite Rule Generator

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

End CyberPanel Generated Rules.

BEGIN LSCACHE

LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block!

<IfModule LiteSpeed
RewriteEngine on
CacheLookup on
RewriteRule .* - [E=Cache-Control:no-autoflush]
RewriteRule .litespeed_conf.dat - [F,L]

marker MOBILE start

RewriteCond %{HTTP_USER_AGENT} Mobile|Android|Silk/|Kindle|BlackBerry|Opera\ Mini|Opera\ Mobi [NC]
RewriteRule .* - [E=Cache-Control:vary=%{ENV:LSCACHE_VARY_VALUE}+ismobile]

marker MOBILE end

marker CACHE RESOURCE start

RewriteRule wp-content/./[^/](responsive|css|js|dynamic|loader|fonts).php - [E=cache-control:max-age=3600]

marker CACHE RESOURCE end

marker LOGIN COOKIE start

RewriteRule .? - [E=“Cache-Vary:,wp-postpass_dc0b5078bedd01200fbf729e7d76bd4f”]

marker LOGIN COOKIE end

marker FAVICON start

RewriteRule favicon.ico$ - [E=cache-control:max-age=86400]

marker FAVICON end

marker WEBP start

RewriteCond %{HTTP_ACCEPT} “image/webp” [or]
RewriteCond %{HTTP_USER_AGENT} “Page Speed”
RewriteRule .* - [E=Cache-Control:vary=%{ENV:LSCACHE_VARY_VALUE}+webp]
RewriteCond %{HTTP_USER_AGENT} iPhone.*Version/(\d{2}).Safari
RewriteCond %1 >13
RewriteRule .
- [E=Cache-Control:vary=%{ENV:LSCACHE_VARY_VALUE}+webp]

marker WEBP end

marker DROPQS start

CacheKeyModify -qs:fbclid
CacheKeyModify -qs:gclid
CacheKeyModify -qs:utm*
CacheKeyModify -qs:_ga

marker DROPQS end

</IfModule

LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block!

END LSCACHE

BEGIN NON_LSCACHE

LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block!

marker BROWSER CACHE start

<IfModule mod_expires.c
ExpiresActive on
ExpiresByType application/pdf A31557600
ExpiresByType image/x-icon A31557600
ExpiresByType image/vnd.microsoft.icon A31557600
ExpiresByType image/svg+xml A31557600

ExpiresByType image/jpg A31557600
ExpiresByType image/jpeg A31557600
ExpiresByType image/png A31557600
ExpiresByType image/gif A31557600
ExpiresByType image/webp A31557600

ExpiresByType video/ogg A31557600
ExpiresByType audio/ogg A31557600
ExpiresByType video/mp4 A31557600
ExpiresByType video/webm A31557600

ExpiresByType text/css A31557600
ExpiresByType text/javascript A31557600
ExpiresByType application/javascript A31557600
ExpiresByType application/x-javascript A31557600

ExpiresByType application/x-font-ttf A31557600
ExpiresByType application/x-font-woff A31557600
ExpiresByType application/font-woff A31557600
ExpiresByType application/font-woff2 A31557600
ExpiresByType application/vnd.ms-fontobject A31557600
ExpiresByType font/ttf A31557600
ExpiresByType font/otf A31557600
ExpiresByType font/woff A31557600
ExpiresByType font/woff2 A31557600

</IfModule

marker BROWSER CACHE end

LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block!

END NON_LSCACHE

BEGIN LiteSpeed

Instrukcijos (eilutės) tarp “BEGIN LiteSpeed” ir “END LiteSpeed” yra

generuojamos dinamikai ir turėtų būti modifikuojamos tik per WordPress filtrus.

Bet kokie pakeitimai instrukcijose tarp šių žymiklių bus perrašyti.

<IfModule Litespeed
SetEnv noabort 1
</IfModule

END LiteSpeed

BEGIN WordPress

Instrukcijos (eilutės) tarp “BEGIN WordPress” ir “END WordPress” yra

generuojamos dinamiškai ir turėtų būti modifikuojamos tik per WordPress filtrus.

Bet kokie pakeitimai instrukcijose tarp šių žymiklių bus perrašyti.

<IfModule mod_rewrite.c
RewriteEngine On

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteRule ^en/wp-login.php /wp-login.php [QSA,L]
RewriteRule ^lt/wp-login.php /wp-login.php [QSA,L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule

END WordPress

ah well that explain why it’s slow to load a page but fast to load a direct link.

So, why is your error.log at INFO level, what’s in the vhost.conf file? loglevel should be at WARN, not INFO

This my page abiti.lt slow to load or which? :slight_smile:

docRoot $VH_ROOT/public_html
vhDomain $VH_NAME
vhAliases www.$VH_NAME
adminEmails info@abitilt.lt
enableGzip 0
enableBr 1
enableIpGeo 1

errorlog $VH_ROOT/logs/$VH_NAME.error_log {
useServer 0
logLevel WARN
rollingSize 10M
}

accesslog $VH_ROOT/logs/$VH_NAME.access_log {
useServer 0
logFormat “%h %l %u %t “%r” %>s %b “%{Referer}i” “%{User-Agent}i””
logHeaders 5
rollingSize 10M
keepDays 10
compressArchive 1
}

index {
useServer 0
indexFiles index.php, index.html
}

scripthandler {
add lsapi:abiti7734 php
}

phpIniOverride {
php_admin_value open_basedir “/tmp:$VH_ROOT”
}

extprocessor abiti7734 {
type lsapi
address UDS://tmp/lshttpd/abiti7734.sock
maxConns 25
env LSAPI_CHILDREN=10
initTimeout 600
retryTimeout 0
persistConn 1
pcKeepAliveTimeout 1
respBuffer 0
autoStart 2
path /usr/local/lsws/lsphp74/bin/lsphp
extUser abiti7734
extGroup abiti7734
memSoftLimit 2047M
memHardLimit 2047M
procSoftLimit 400
procHardLimit 500
}

context /.well-known/acme-challenge {
location /usr/local/lsws/Example/html/.well-known/acme-challenge
allowBrowse 1

rewrite {

}
addDefaultCharset off

phpIniOverride {

}
}

rewrite {
enable 1
autoLoadHtaccess 1
logLevel 0
RewriteRule ^/(xmlrpc|wp-trackback).php - [F,L,NC]
}

vhssl {
keyFile /etc/letsencrypt/live/abiti.lt/privkey.pem
certFile /etc/letsencrypt/live/abiti.lt/fullchain.pem
certChain 1
enableECDHE 1
renegProtection 1
sslSessionCache 1
enableSpdy 15
enableStapling 1
ocspRespMaxAge 86400
}

module cache {
storagePath /usr/local/lsws/cachedata/$VH_NAME
ls_enabled 1
}

well yeah that site always have like 4 seconds of delay, then it download the page in mere millisecond from cloudflare, very odd behavior, really slowed me down to check all the pretty girls in fancy clothes.

Well you’ll have to check further to know why it’s logging INFO instead of just WARN or ERROR level, go through all the server config and look for loglevel, there used to be a bug in litespeed ( endless rewrite logs ) but that was fixed. Maybe httpd_config.conf?

But I am using Openlitespeed, I don’t change anything for these directories


How about log-level in rewrite tab?

I set 0 now. For me was 9. I disabled it

Well if it was at 9, then that was it.

That should do it.

So i can leave 0. And this will turn off this info?