Failed to obtain SSL issuing self-signed SSL

I’ve turned it on to see if it makes a difference, but had it off from the beginning - same problem, unfortunately.

Login to ssh and execute this command. Replace YOUR_DOMAIN with your actual domain name

/root/ --issue -d <YOUR_DOMAIN> -d www.<YOUR_DOMAIN> --cert-file /etc/letsencrypt/live/<YOUR_DOMAIN>/cert.pem --key-file /etc/letsencrypt/live/<YOUR_DOMAIN>/privkey.pem --fullchain-file /etc/letsencrypt/live/<YOUR_DOMAIN>/fullchain.pem -w /home/<YOUR_DOMAIN>/public_html --force --debug

That seemed to have changed something. It now has a

SSL from ZeroSSL. Your SSL will expire in 90 days.

in the CP section, but when I go ot the domain with WP installed, still a self-signed cert… :face_with_head_bandage:

Cyberpanel is using letsencrypt ssl provider and not zerossl. You maybe using olded cyberpanel version. Please upgrade.

I’m using the current v2.1 buidl 2

Just run the upgrade command again as minor bugfixes doesnt change the version numbers for cyberpanel.

Sorry, the apt-update or under CP

Use this code:

sudo sh <(curl || wget -O -

Please refer this:

OK I got it to work on another domain. Thanks!

Cyberpanel was created to make it easier to create websites, but the opposite is happening. Those processes that should be performed automatically do not occur at all! I can’t access the new site I created because the cyberpanel didn’t create the htaccess file Even if I manually create this file, the site is still inaccessible because a self-signed ssl certificate has been issued. Give me some advice, maybe it will be easier for me to create sites without a cyberpanel, but just through the terminal? Instead of creating a site in one click, as they say in presentations, I work weeks and months without a solution to the gap. at the moment my site is created, but I have a multiple redirect error, and I do not have access to the site. ssl released self-signed. But mail on the domain works fine, dns responds. Буду благодарен за помощь и совет.

Maybe something is wrong with your setup then. From where have you purchased your domains from?

i tried to create a site on subdomain and same thing, cyberpanel doesn’t create htaccess file, issue self-signed certificate, i don’t have access to the site. For example, I have a valid site on the domain, I create the subdomain and get the same result as with the domain

The problem was solved. I deleted my site and just created it again. The only difference from what I did is that I chose a different version of PHP, when choosing version 7.4 everything works fine. Last time I chose version 8.0

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.