error when upgrading

trying to upgrade from 1.9.1 to the latest here are the errors i received
Error Summary

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

command failed, exiting…

I get this when i run # pip install --upgrade pip
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process - pip documentation v22.0.dev0
Requirement already up-to-date: pip in /usr/lib/python2.7/site-packages (20.0.2)

yes

its installed, i had to force it to use it. this is the error i get still though The path /usr/bin/python3 (from --python=/usr/bin/python3) does not exist