Empty php 7.4 config folder

Hello, I have a problem with phpmyadmin (white screen) so tried to go to PHO config in cyberpanel and found this error:

cat: /usr/local/lsws/lsphp74/etc/php/7.4/litespeed/php.ini: No such file or directory

and in advanced tab:

then, went to that folder and is empty:

My current version:


I always get this type of problem with default PHP version in Ubuntu 22.04, any help that don’t involve install everything from scratch?

Kind regards

Just added this php.ini on that folder, seems to work - but phpmyadmin still white

php ini copied to that folder: https://raw.githubusercontent.com/usmannasir/cyberpanel/a2833ad70a827ba89938c0528333df5f199dfede/install/php-configs/php.ini?v=2

Hello @ininges See this to reinstate phpmyadmin Phpmyadmin go blank - #2 by josephgodwinke

Thanks Joseph,

the problem is that the folder does exists and is not empty - the problem is not with phpmyadmin but lsphp74.

Some times, after an update I manage to make it works until next update doing that:

mv /usr/bin/php /usr/bin/php_old_2
ln -s /usr/local/lsws/lsphp80/bin/php /usr/bin/php

But with the latest update it doesn’t work.

I believe everything is related with this error:

/usr/local/lsws/lsphp80/bin/php --version
PHP 8.0.27 (cli) (built: Jan 10 2023 02:55:48) ( NTS )
Copyright (c) The PHP Group
Zend Engine v4.0.27, Copyright (c) Zend Technologies
    with Zend OPcache v8.0.27, Copyright (c), by Zend Technologies
root@lemonjuice:/usr/local/CyberCP/public/phpmyadmin/tmp# /usr/local/lsws/lsphp74/bin/php --version
PHP Warning:  **Cannot load module 'redis' because required module 'json' is not loaded in Unknown on line 0**
PHP 7.4.30 (cli) (built: Aug 10 2022 01:29:52) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with the ionCube PHP Loader + ionCube24 v12.0.5, Copyright (c) 2002-2022, by ionCube Ltd.

And all extensions are installed

Partially fix, did that:

sudo vim /usr/local/lsws/lsphp74/etc/php/7.4/mods-available/json.ini

; configuration for php json module
; priority=20

But phpmyadmin still white, even in a new window. ¿Where is the phpmyadmin log?

Kind regards

After that, phpmyadmin still not working but at least show an error:

Tried to do an install but fails:

Unable to locate package lsphp74-mysqli

Also, all extensions seems to be installed for that php version.