Emails not working everything else works

I installed the server, everything worked out of the box except emails.

I checked postfix config file vi /etc/postfix/
It still had localhost.localdomain hostname, rather than the one given during installation. Changed it to correct one. restarted postfix, postfix status is active and running.

Tried turning off and on postfix from Manage service → Manage postfix, but still no luck.

Email log also does not populate with error tail: cannot open ‘/var/log/maillog’ for reading: No such file or directory

Any help is appreciated.

I have fixed the log file missing issue with following commands via SSH

yum install rsyslog
systemctl enable rsyslog
systemctl start rsyslog

Log started working. I see domain dkim missing error in log, I tried generating DKIM key from Mail → DKIM Manager, I had “Keys not available for this domain. Generate Now” before.

Getting following error when trying to generate it:
substring not found

How did you install CyberPanel? And did you go through How to get 10/10 Email score using CyberPanel - YouTube

yes, everything required is setup except DKIM key, when I try to generate it gives me error “substring not found”.

Please check why this error shows up in programming. Thanks

1 Like

If you are in Centos 8 or Almalinux just install this
yum install opendkim-tools

if you are in debian or ubuntu …

sudo install opendkim-tools

Tested and wordked 100%

1 Like