CyPanel 2.3 | index.html > 404

I created 5 websites and added LE SSL to all: everything works.
Then I followed the same procedure for has no files, just SFTP access (which works fine) + CFlare DNS pointing to the VPS. (no proxy, SSL: flexible, purged Cache)
I uploaded index.html and tried to reach it | got 404

I checked OLS VirtualHost and it looks like my other (working) websites (attached)
I’ve seen the following posts, and restarted the VPS.
I deleted and recreated
I restarted OLS | nothing worked.

systemctl restart lsws

Looking at the /error.log below it seems the OLS Listener does not exist.
But OLS Panel says the Listeners are on SSL + Unsecure , so should be served. (attached)

2023-12-16 10:55:18.443753 [INFO] [1854] [PlainConf] [virtualHostConfig:] Finished parsing file /usr/local/lsws/conf/vhosts/
2023-12-16 10:55:18.443784 [INFO] [1854] [PlainConf] [virtualHostConfig:] module [cache] add param [storagepath /usr/local/lsws/cachedata/$VH_NAME]
2023-12-16 10:55:18.444271 [NOTICE] [1854] [] 'Process Limit' probably is too low, adjust the limit to: 640.
2023-12-16 10:55:18.446171 [INFO] [1854] [] config context /.well-known/acme-challenge.
2023-12-16 10:55:18.446630 [INFO] [1854] [PlainConf] [virtualHostTemplate:] start parsing file /usr/local/lsws/conf/templates/ccl.conf
2023-12-16 10:55:18.447336 [INFO] [1854] [PlainConf] [virtualHostTemplate:] Finished parsing file /usr/local/lsws/conf/templates/ccl.conf
2023-12-16 10:55:18.447364 [INFO] [1854] [PlainConf] [context:/] rewrite [] add rules [rewritefile .htaccess]
2023-12-16 10:55:18.447561 [ERROR] [1854] [config:template:centralConfigLog] Listener [Default] does not exist

Can anyone help?
Many thanks

[1] 404 Error on my websites - #12 by roman
[2] New website returns 404 and log files wasn't created on the server
[3] ** SFTP
[4] ** OLS
[5] *** CFlare DNS
[6] ** 404
[7] ** root OK (default index.html - not my file)
[8] How to turn on Extensive Debug logs in OpenLiteSpeed!
[9] ** Default OLS Listener (secure & unsecure)

Kindly ensure your topic meets the requirements here How to ask for assistance? - Docs / 20 - Miscellaneous - CyberPanel Community to better address your issue

Thanks Jose

Please have more details as below:

CyPanel Current Version: 2.3
Build: 4
Current Commit: c8da443334b8815ec250a0fba606e75355f641cd
Latest Version: 2.3
Latest Build: 4
Latest Commit: c8da443334b8815ec250a0fba606e75355f641cd

Ubuntu 22.04


docRoot                   $VH_ROOT/public_html
vhDomain                  $VH_NAME
vhAliases                 www.$VH_NAME
adminEmails               [email protected]
enableGzip                1
enableIpGeo               1

errorlog $VH_ROOT/logs/$VH_NAME.error_log {
  useServer               1
  logLevel                WARN
  rollingSize             10M

accesslog $VH_ROOT/logs/$VH_NAME.access_log {
  useServer               0
  logFormat               "%h %l %u %t "%r" %>s %b "%{Referer}i" "%{User-Agent}i""
  logHeaders              5
  rollingSize             10M
  keepDays                10
  compressArchive         1

index  {
  useServer               0
  indexFiles              index.php, index.html

scripthandler  {
  add                     lsapi:bluep3632 php

extprocessor bluep3632 {
  type                    lsapi
  address                 UDS://tmp/lshttpd/bluep3632.sock
  maxConns                10
  env                     LSAPI_CHILDREN=10
  initTimeout             600
  retryTimeout            0
  persistConn             1
  pcKeepAliveTimeout      1
  respBuffer              0
  autoStart               1
  path                    /usr/local/lsws/lsphp81/bin/lsphp
  extUser                 bluep3632
  extGroup                bluep3632
  memSoftLimit            2047M
  memHardLimit            2047M
  procSoftLimit           400
  procHardLimit           500

context /.well-known/acme-challenge {
  location                /usr/local/lsws/Example/html/.well-known/acme-challenge
  allowBrowse             1

  rewrite  {
    enable                0
  addDefaultCharset       off

rewrite  {
  enable                  1
  autoLoadHtaccess        1

module cache {
storagePath /usr/local/lsws/cachedata/$VH_NAME

vhssl  {
  keyFile                 /etc/letsencrypt/live/
  certFile                /etc/letsencrypt/live/
  certChain               1
  sslProtocol             24
  enableECDHE             1
  renegProtection         1
  sslSessionCache         1
  enableSpdy              15
  enableStapling           1
  ocspRespMaxAge           86400

Rewrite Rules: (no files in my website yet)

cat: /home/ No such file or directory

Why the 404 page return Apache 404 when OLS is supposed to run ?
Apparently Apache is not running on my server.

> httpd -v
> Command 'httpd' not found

But, if I search for it, I get lots of files, and the Apache 404 is triggered only for
If I type a non-existent url for any of my other domains, I get a OLS 404 (not Apache)

Eventually I found the problem, it was a CyPanel BUG.

Initially reported by @vpsingh 6mo ago, I hope someone will look into it . Perhaps Syed, @josephgodwinke @die2mrw007
After struggling for a week , here is my understanding of the issue , and my workaround to fix it in 2 mins - hopefully without breaking anything else.

Although OLS is the HTTP server, Apache2 is also installed by CyPanel., was in fact served by Apache2 (which is just Apache for Ubuntu), though OLS is installed and running. That’s why I got the Apache2 404

Check this out via SSH:

apache2 -v ** Server version: Apache/2.4.52 (Ubuntu)
grep -r Listen /etc/apache2/* // List Apache2 active ports

Now, open /etc/apache2/apache2.conf and comment the line below:

#Include ports.conf    ** This prevent Apache2 to listen to any ports (80, 443)

Restart Apache2, Done!
Finally my index.html was served by OLS. :slight_smile:

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.