Cyberpanel installation error 1

The error code is:

./ line 181: /root/ No such file or directory

/root/ --upgrade --auto-upgrade has failed for 49 times
Wait for 3 seconds and try again…

command /root/ --upgrade --auto-upgrade failed for 50 times, exit…

Help, anyone knows how to solve it, thank you very much

Please provide these details:

  • Hosting provider name
  • Operating System Installed along with the version number
  • Are you running the installation/upgrade command using root user?
1 Like

1.Google Cloud、

There is no such operating system available on earth. And even if it exists, cyberpanel doesnt support it yet.

I tried many times and it keeps getting this error

Operating system is centos7


Is the VPS located in India? If so, Indian government has blocked the site and VPS using Indian ISP will get this error.
You can shift the location or use different ISP in VPS if there is such option provided by Hosting provider and try again.

No,Location in Los Angeles

login to your server and ping and see if its connecting.

PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=62 time=1.67 ms
64 bytes from ( icmp_seq=2 ttl=62 time=2.13 ms
64 bytes from ( icmp_seq=3 ttl=62 time=2.00 ms
64 bytes from ( icmp_seq=4 ttl=62 time=1.84 ms
64 bytes from ( icmp_seq=5 ttl=62 time=1.84 ms
64 bytes from ( icmp_seq=6 ttl=62 time=2.00 ms
64 bytes from ( icmp_seq=7 ttl=62 time=1.95 ms
64 bytes from ( icmp_seq=8 ttl=62 time=1.97 ms
64 bytes from ( icmp_seq=9 ttl=62 time=2.06 ms

Do you know what the problem is

Your logs were incomplete… Hence unable to understand the real reason for the issue.

Now try again in fresh vps setup and see how it goes through. Let me know if any issues you face in new setup

As you mentioned your hosting provider is google cloud, it has its own firewall system. You will need to unblock various port numbers while setting up the vps. You can google it to know how to configure your firewall settings to setup vps.

@yes37 run cyberpanel upgrade command and let me know after that

We have just purchased the server and newly installed it

We tried again many times, but it’s still the problem

Branch ‘v2.1.2’ set up to track remote branch ‘v2.1.2’ from ‘origin’.
Switched to a new branch ‘v2.1.2’
Cloning into ‘’…
remote: Enumerating objects: 14232, done.
remote: Counting objects: 100% (10/10), done.
remote: Compressing objects: 100% (9/9), done.
remote: Total 14232 (delta 1), reused 3 (delta 1), pack-reused 14222
Receiving objects: 100% (14232/14232), 5.17 MiB | 18.99 MiB/s, done.
Resolving deltas: 100% (8618/8618), done.
[Sat Dec 25 09:34:01 UTC 2021] Please install openssl first. ACME_OPENSSL_BIN=openssl
[Sat Dec 25 09:34:01 UTC 2021] We need openssl to generate keys.
[Sat Dec 25 09:34:01 UTC 2021] Pre-check failed, can not install.
./ line 181: /root/ No such file or directory
/root/ --upgrade --auto-upgrade has failed for 1 times
Wait for 3 seconds and try again…
./ line 181: /root/ No such file or directory

If possible do PM me the server login details and I will try to install it and see

@yes37 You can use the Google Cloud Marketplace to install CyberPanel directly incase there is no solution.