Cyberpanel installation destroys my existing database

Hi. I’m new to Cyberpanel, but not to MySQL. I’m trying to install it on my server, which has already a running, production database (MySQL 8.x). Furthermore, I’ve followed the complete procedure to install it using a remote database, located on some other server.
Before installing cyberpanel, I’ve checked that my main server can connect to the remote database server, which I need to use. The remote database server has a MariaDB installation running that I installed for this purpose.
I can connect from my mine server to the DB server manually, by command line perfectly. Then, I did a backup of my main server and started the Cyberpanel installation.

At the point where the script asks me to install the database, whether local or remote, I choose remote. It then asks me for the connection data (host, user, pass, etc.) I can see it connects perfectly and even creates the remote databases without any issues.
The installation ends with no errors. I then tested Cyberpanel by accessing via the URL plus the port 8090 and everything looked good. When I try to use my main server local apps, it tells me that they can’t connect to the local database. I then checked using MySQL command to access locally, but it cannot connect to the DB, neither local nor remote. The local database doesn’t start any more.
I’ve tried this procedure some three times and I have the same result. It looks like Cyberpanel has installed MariaDB OVER my local MySQL and none of them starts. No idea why the Cyberpanel script asks for a local or remote DB install, when it finally installs MariaDB soft both local and remote, without any permission. Am I doing anything wrong? Is there any way to install the DB remotely ONLY, without destroying my local existing installation? Thanks!