Cyberpanel delete all files and directors public_html

Hetzner maybe? Well Hetzner has 2 VPS type: virtual core or dedicated core. The price is about 6€-35€ for virtual or dedicated.

Is this virtual what you say legacy?

Thanks in advance for the info.

The major drawback I see about contabo is their limited lower network port speed. Usually many recognized providers provide roughly 1GBps public port speed atleast nowadays and it matters/impacts a lot in your overall website performance too.

Hi, i think the issue may be related to almalinux 8.5 i justi instaled 2 days ago de 2.1 version and the problem persisted, upgrading a get a lot of messages and the issue persists.

Can you clariffy if the support of alamalinux 8 dont include alma linux 8.5
I also have issues with the powertools cyberpanel repo, probably because of Centos EOL

In my instalation i didnt install powerdns and email services

Hello everyone

I’ve double/tripple checked the code. But can not find any remove code, kindly force update to v2.1.2 and you should not have this issue.

If you still face issue after upgrading, then let me know.


Do you mean

Current Version 2.1
Build 2

sorry i’m new to cyberpanel

You can again run the update using 02 - Upgrading CyberPanel

Even if you are on latest version, it will pull out all the latest files.

can you point me to the issue that was corrected to check if the updates i tried changed the needed files

I am on version 2.1 lost all the files including the public_html folder. Had backups only for 2 days and it is not even there so lost everything. 6GB worth of data, is there any way to recover this?

If you are using centos please switch to ubuntu for future projects.

This issue has been solved long time ago, kindly everyone upgrade using the guide I shared above.

Sorry to infor that it doesnt look like it, please point me to the source code location so that i can check in my install. i think this is related to quota management and almalinux or other Centos flavors, please help me helping you

just upgrade your cyberpanel dude

This is not good enough to deploy on production servers if it is a serious project. I think it is still not ready yet…

Why u here then ?

cyberpanel have their own market
at my first experience with cyberpanel
i have same though with you
but after i read the history of cyberpanel
now i have my own opinion
cyberpanel is good for personal use
if you want use panel for commercial (sry cyberpanel’s team) i recommend you cwp… $1-$2 / month for multiple php site … they have free version too but with some limitation

now, because i manage many website
i use 3 server (vps) with 3 cyberpanel (because i manage them)
1 cpanel reseller hosting :smiley: (cpanel only for person that want to manage their own site or panel)

acutally if @usmannasir @usmannasir1 @die2mrw007 can make cyberpanel like VistaPanel and/or cpanel (not vesta) only the link tree not the GUI(but the GUI is good :stuck_out_tongue: ) or other bloat
cyberpanel will enough for everyone.

some of feature that i still hoping cyberpanel will have

  1. email forwarder
  2. Filemanager for root
  3. user themes
  4. optional enable disable awstat

and fix the tool’s flow (more like vistapanel or cpanel) just the link tree not the bloat :smiley:
like open new window on filemanager and other think
i hope …
but if they said no…
it’s ok
this is their panel. i believe they have big blue print.

Just upgrade to 2.1.2 :frowning:

i did it, its still the same thats why i want to confirm possible issue with the upgrade. i believe the problem is not in cyberpanel but in the OS please point me to the bug file and line or commit so that i cant confirm my thesis

Just to make my point, the server was clean installed on 18 of Feb, if the bug is from September why the install script still install the bugged version?

you need to learn about programming…

btw… have you already update or just want to argue ?

I started programing when i was 10 with help of my brother, started learning to program in school when i was 15, graduate in computer engineering and have a small cloud services company.

I run the upgrade script, but as i said the server was installed 7 days ago, the bug is from September i ask if the install script keeps installing the version with a major bug?

What i need is to be pointed to the bug so that i can confirm if there is a problems with my server(SO related) that makes de upgrade not to finish, the files date are all update to the date of the day that i run the upgrade script so the upgrade changed the files so i need to check if the file with the bug is realy updated to the corrected version.

confirmed, can you change the post title?