Create Backup Doesn't Work After Upgrade to 1.8.7

I upgraded to latest cyberpanel version 1.8.9 but still backup is not working it shows completed but with no size & backup files, I have installed cyberpanel on GCP can anyone confirm if backup is working on other providers in the latest version 1.8.9 of cyberpanel.

i could try what steps u take and feedback.

@cybertech

I updated the panel & than navigated to backup sections in admin → Back up Website from dropdown → selected website → Destination = Home than create Backup

After some second it shows below message

Running backup-gcprapi-09-33-35-Tue-Aug-2019 Making archive of home directory.

After that it shows me below screen check the pic → Screenshot, 2019-08-13 12:37:02 - Paste.Pics

I didn’t added any remote backup destination so can’t comment on remote backups.

Thanks.

@cybertech

I updated the panel & than navigated to backup sections in admin → Back up Website from dropdown → selected website → Destination = Home than create Backup

After some second it shows below message

Running backup-gcprapi-09-33-35-Tue-Aug-2019 Making archive of home directory.

After that it shows me below screen check the pic → Screenshot, 2019-08-13 12:37:02 - Paste.Pics

I didn’t added any remote backup destination so can’t comment on remote backups.

Thanks.

mine looks the same, size is 0, but when i navigate to the actual backup folder, its there and complete size.

I can also confirm as I checked by navigating to the home/domain/backup the tar.gz file is their but it showing 0 size in the admin panel.

Also on restore backup option is it not showing anything in the dropdown while their is backup file in home directory.

@CyberPanel can you check this with latest version for local backups in cyberpanel installation.

If you go here → 1 - Backup/Restore - CyberPanel

This says Place your backup files under /home/backup/

In short you need to move generated backup files in /home/backup. CyberPanel will only detect .tar.gz files in /home/backup, not inside childs of /home/backup.

I can’t reproduce any of the issue mentioned in this thread, except schedule backups are not working due to cron failure which I am looking into.

@CyberPanel

So how to place backup files in home/backup/, as I see currently their are no folder in home directory named backup.

When I visit the create backup option it shows the dropdown of websites → after selecting a website it shows dropdown destination as home & then a button to create backup.

The directory home/domain/backup is created when I click on create backup button, I do not have option to specify backup location in the process.

On click to create backup button it shows below message:

Running backup-gcprapi-09-33-35-Tue-Aug-2019 Making archive of home directory.

After that it shows me below screen check the pic → Screenshot, 2019-08-13 12:37:02 - Paste.Pics

Do I need to do anything else here.

@cloudrider

Good your backup is completed. Now to restore

  1. mkdir /home/backup
  2. mv /home/domain.com/backup/backupfile.tar.gz /home/backup
  3. Delete this site.
  4. Restore from the CyberPanel interface.
schedule backups are not working due to cron failure which I am looking into.
Is this fixed in 1.8.9?
schedule backups are not working due to cron failure which I am looking into.
Is this fixed in 1.8.9?

Yes, i can confirmed this issue fixed.