Can't connect to server snappymail error message

I receive the error message “can’t connect to server” when I click on “send” an email in snappymail. I also cannot receive emails from anybody (or send to anybody, be it gmail address or my own domain addresses). What can be the issue here?

Welcome @ckjm Happy New Year

Go to https://SERVER_URL:8090/snappymail/?admin#/domains and setup the SMTP connection for all domains by clicking on the asterisk (*) you see on list of domains

Post a screenshot here if a test fails

Problem: I’m unable to login, there is a message sayin “Authentication failed”. I’m using the same credentials that I login to https://SERVER_URL:8090/snappymail/ where it’s working fine but failing on https://SERVER_URL:8090/snappymail/?admin#/domains
So I guess those aren’t the credentials I should use there? Are there others?

Just now I tried to deactivate some wordpress plugins and tried to reboot again my server and guess what, the emails start going as if nothing happened; (I did reboot the server yesterday but it didn’t do anything). Could it be plugin related? I just reactivate all of them and nothing happens, the emails are still going just fine. So my problem is resolved, but if you ask me what was the solution, it must be related to rebooting the server or plugins issue. I can’t tell with certainty. Just tried both and that did the trick for me!

Check the email logs and post them here we hsould identify why so that in future we cannot run into same problem with not actually knowing why