Cannot install cyberpanel fresh install

tried alma, rocky, ubuntu server. All 3 stop with the same error:

error: subprocess-exited-with-error

× python egg_info did not run successfully.
│ exit code: 1
╰─> [1 lines of output]
error in decorator setup command: use_2to3 is invalid.
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

pip install --default-timeout=3600 -r /usr/local/requirments.txt has failed for 4 times
Wait for 3 seconds and try again…

checked python version with:
python3 -V
Python 3.10.6

too many tires. Giving up…

after many attemps, finally installed fresh ubuntu server 22.0.4, came with python 3.10, gave this error. then issues:
pip install --upgrade pip setuptools==57.5.0
then re-run setup, did some stuff and said installed continue, and stopped.
re-run setup sh,
after 8min, no complain, panel installed.
happy hosting :slight_smile:

Hello @troy

Which branch did you choose during installation ?

Can’t install Cyberpanel.

Os Ubantu 20.04

I just did enter in that question and it showed 2.3