Cannot access cyberpanel help please

Hello guys I have created 3 containers one for haproxy one for CentOS and another Ubuntu . I use haproxy container to reverse proxy the request .
I installed cyberpanel following the official website sh script and installed it in CentOS container . Used iptables to route to respective containers. Till now everything was working fine but i moved to my production Vps did the same exact steps but now cyberpanel is not loading . I even did systemctl lscpd restart even though the page says err connection reset. Inside the container I used curl the response was failed to connect.

Can you please help me out

if you “netstat -lnp | grep 8090” , do you see 8090 port ?

@qtwrk said:
if you “netstat -lnp | grep 8090” , do you see 8090 port ?

Yeah I solved it I am writing my solution here I forwarded 8090 port to my conteiner ip address with iptables even though it wasn’t working but later I came to know I had SSL on cloudflare so I switched off the SSL and it worked.