[BUG] DKIM Signature verification failed

Hello, i am wondering about the Dkim that tries to validate Hotmail mail.
I have done the 10/10 tutorial below, and all emails are sent through, but only Gmail e-mails are sent with valid dkim, email do get through, but not as valid.

Hotmail comes as this image.

Gmail comes as this image:

Cloudflare DKIM setup:

Achieve 10/10 Email score with CyberPanel! - Blog Posts - CyberPanel Community

I am also facing the issues the dkim
error DKIM Signature Body Hash Verified
anyone have any idea about that @usmannasir

@Master3395 @abdul545

The issue you are all having is DKIM signature Body hash not verified indicating that you are using third party applications to send emails which change the composition of the email body.

First check if your DKIM records are correct on cloudflare also try sending an email through snappymail to hotmail and see if you get same result

1 Like

Bro I am sending emails through snappymail
and Bro if I send emails through mail wizz or snappy mail I got the same dkim signature body hash issue

Can you generate new DKIM Keys and try again? Make sure to change DKIM record on your dns manager - cf

1 Like

ok my dear brother thanks for your help

bro I have done it but the issue is not solved yet check the screen shots

You sent the email using snappymail ?

yes brother

I have tried checking it all.

sending e-mail to hotmail from cyberpanel (Snappymail) makes dkim invalid.
Sending it through gmail works fine.

Cloudflare has the dkim, but for some reason, CyberPanel does not generate a new DKIM in any way.
All I can do is fetch the existing DKIM:

Resultat av Spam-test (mail-tester.com)

I gave up on trying to find a solution.
I had to get my ISP to give me advice on blacklisting from Microsoft, so I got that working.
But sadly DKIM does not work with CyberPanel anymore.

I have asked for support lately, but all they said was this:

You are 100% right.
It works now!

I’m facing the same issue running latest Cyberpanel Version on Ubuntu 22.04.3 LTS.
The opendkim.conf looks like this, so it looks like your provided solution:

# Socket for the MTA connection (required). If the MTA is inside a chroot jail,
# it must be ensured that the socket is accessible. In Debian, Postfix runs in
# a chroot in /var/spool/postfix, therefore a Unix socket would have to be
# configured as shown on the last line below.
Socket  inet:8891@localhost
#Socket                 inet:8891@localhost
#Socket                 inet:8891
#Socket                 local:/var/spool/postfix/opendkim/opendkim.sock

PidFile                 /run/opendkim/opendkim.pid

Any ideas on that?


This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.