All SSL connections stop working 24-48 hours later

I’ve recently begun using CyberPanel on Ubuntu 18.04. I also tried on Ubuntu 20 with the same result. The problem goes like this: I image the server, install CyberPanel and add websites. I already have the domains pointed to the server.
At first, it works wonderfully. The sites have secure SSL connections, I’m able to install WordPress. Then 24-48 hours later, https:// connections no longer work. http:// connections still work, but I’m no longer able to view sites on https. I get ERR_TIMED_OUT or ERR_CONNECTION_CLOSED errors.
I’ve gone through this three times, twice with Ubuntu 20 and once with Ubuntu 18. The last time, I checked the listeners, firewall, and virtual hosts in the LiteSpeed control panel and everything appeared to be correct. I’m getting the same errors when trying to access the LiteSpeed web panel so I can’t see what it looks like now.
This was the log output after trying to access one site:

[12.06.2021_02-04-27] Trying to obtain SSL for: fastbeautytips.com and: www.fastbeautytips.com
[12.06.2021_02-04-27] /root/.acme.sh/acme.sh --issue -d fastbeautytips.com -d www.fastbeautytips.com --cert-file /etc/letsencrypt/live/fastbeautytips.com/cert.pem --key-file /etc/letsencrypt/live/fastbeautytips.com/privkey.pem --fullchain-file /etc/letsencrypt/live/fastbeautytips.com/fullchain.pem -w /home/fastbeautytips.com/public_html -k ec-256 --force --server letsencrypt
[12.06.2021_02-04-28] Failed to obtain SSL for: fastbeautytips.com and: www.fastbeautytips.com
[12.06.2021_02-04-28] Trying to obtain SSL for: fastbeautytips.com
[12.06.2021_02-04-32] Successfully obtained SSL for: fastbeautytips.com
[12.06.2021_02-04-32] {'xxxxxxxxxxx@gmail.com': (554, b'5.7.1 <xxxxxxxxxxxx@gmail.com>: Relay access denied')}

I can’t understand why everything works for a day or two, and then stops. The problem usually occurs overnight, so I think it’s nothing I’ve done.
I really want to get this working. I only learned about LiteSpeed recently. I’ve been using WHM on CentOS for years. I initially tried to install CyberPanel on CentOS and then AlmaLinux but there was some problem when the auto installer tried to install one php. I’ve been working with this SSL problem for about a week now. If I can’t get it working I’ll sadly go back to Apache.

please make sure your sites arent behind Cloudflare proxy while issuing SSL.
You can try Almalinux 8.5 if you are coming from CentOS for years. Or else Ubuntu 20.4 LTS version works fine.

Try again and let me know how it goes around. I will help you out on this for sure.

I appreciate that, but I ended up reimaging the VPS with Centos 7. I don’t have any particular preference for OSs as long as the control panel and server function. After reimaging, I installed CyberPanel with no problems, then added my default nameserver, then did the “Issue SSL for Hostname”, but when I go to login using the hostname it isn’t secure. I added another website and went to that domain. I can see the default web page under http, but not securely under https.
I’m using the same nameserver as before. Should I use a different one? Or is there some way to cancel the certificate and redo it?

PM me what exactly you did including mentioning of domain names and nameserver details. You said you issued ssl for hostname, just let me know which domain name you selected for hostname and what are the error logs for the same. PM me all these details as this is public forum and sharing such sensitive details aren’t advised.

Was this issue resolved? I am facing the same problem.

It’s working for me OK now. I reimaged with AlmaLinux and installed everything again, but I can’t remember what fixed it.