404 not found website on a freshly created package/user/website

Since I wanted to use something newer and avoiding cpanel/whm, I decided to use the cyberpanel with ols and mariadb, so far so good, I initially set up a website under my admin default account / package and I can access it without any problems.
Seeing that, I wanted to bring my other websites in this new VPS.
However, If I create a new user / package / website and try to access the domain, I am getting a 404 not found page.
These are the steps i did:

  1. Create a new package, name: basic, domains: 1, disk space: 1000mb, bandwidth: 0, ftp accounts:1 db: 1 , emails: 1, Allow Creation of Fully Qualified Domain as Child-Domains enabled by default.
  2. Create a new user: security level: high, ACL: User
  3. Create a new website, by selecting the package and user I earlier created
  4. create the db: import my existing db via phpmyadmin
    and so far looks like is pointing to the general default web page of the server ip.

can you please tell me what’s wrong with this?

Please advise. thank you very much.

Welcome @mish Happy you are here

Fix file permissions and check reWrite rules

Go to List Websites → mydomain.com → File Manager → Fix Permissions

Go to List Websites → mydomain.com → Rewrite Rules ( clear everything you see)

And test again if you get the error

Hello sir and thanks for your reply,
I tried following your suggestions and so far nothing changed.
Another thing that make no sense is the fact that I am able to preview the website by going to list websites → Manage website → https://SERVERIP:8090/preview/mydomain.com/ but if i click on any link from there it throws me 404 not found, I tried accessing any content of public_html just to make sure this points to the proper folder and so far everything throws 404 errors. i checked htaccess and except default wp entry, there is nothing else, i even cleared the cloudflare caching , rebooting the server and the issue unfortunately still persists. will try today to delete the package / user / website I created and will try again, if this fails, it’s clear that I have to abandon cyberpanel due to obvious reasons

Run the upgrade script once and reboot your server

I ran the upgrade script via terminal using cyberpanel_utility command and rebooted the server, nothing changed, the issue still present.

You need to disable modsecurity and any other firewalls and test if issue still persists.

there is nothing to disable as mod sec is not installed on my server.
I thank you for your time and for trying to be helpful but this has nothing to do with modsec or any other fw rules as im not experiencing connectivity issues but looks like an internal error generated by this cyberpanel which i started being quite disappointed. I respect and appreciate every single individual who contributed for this project but for me is not something reliable at all., since i purchased it i destroyed the vps instance couple times because of the very nonsense elements i was encountering such as: 1 fresh install, i was able to import a db inside phpmyadmin, another try, the server failed to do so, another try, it worked. I have no custom modifications made to the server except the only required elements for cyberpanel . at this point i cant use it and i cant risk compromising my properties just to serve as a experiment id like to thank you for your help but this mostly work for someone who has a personal website and would like to avoid the licensing stuffs from cpanel by going for a free alternative .will consider giving another try in the future when things will be properly fixed as im seeing lots of complaints and i really want to avoid troubleshooting things for days just to spin in a circle… I even connected that cyberpanel instance to your cloud and because of the "sql recommendations your system suggested, it ended up in literally messing up my whole server by being greeted with error 500 everywhere, from my website to the admin dashboard. im not an experienced devop but im not a newbie either and seeing that from day 0 i had a lot of difficulties trying use this as a replacement for my existing subscriptions and instead of making things work, im stuck at troubleshooting things… again, thank you for your help. best regards

Maybe its the server os. Which os are you running ?

centos 7, latest cyberpanel build

Wrong move. This os is highly discouraged for new installations.

Server with a fresh install of Centos 7.x (Not recommended for new installs), Centos 8.x, Ubuntu 18.04, Ubuntu 20.04, AlmaLinux 8, Ubuntu 22.04

I highly recommend Ubuntu 20.04 but if you like RHEL oses use AlmaLinux 8.3 - 8.4.

Kindly give it a try and revert back here for support. Thank you

oh, thank you for this , will try to see what the hosting has available in terms of OS as I tried AlmaLinux 9 but cyberpanel does not work yet with that one.

is it ubuntu 22.04 okay? or 20.04 better?

Server with a fresh install of Ubuntu 20.04, Ubuntu 22.04, CloudLinux 7, CloudLinux 8, AlmaLinux 8, AlmaLinux 9.

Personally I have currently tested on AlmaLinux 8.3 - 8.5, Ubuntu 20.04 only. And those have worked flawlessly since 2023.